FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12688 questions

15067 answers

24145 comments

47112 members

0 votes
259 views 4 comments
by
Hi there,

I recently bought a Teltonika RUT X50 and I cannot get 5G mobile connection to work.

I selected the "5G only" mode in settings and tried different 5G activated SIM cards in the RUT X50 - no success with any (Operator state "unregistered"). However, I know there is 5G coverage at the router's location and that the SIM cards work in 5G mode (having tested them separately in my mobile phone).

With "4G+5G" selected in settings, the router connects with 4G with all SIM cards I have tested. It seems there is a bug in "5G only" setting?

Firmware version is RUTX_R_00.07.02.8.

Logread attached

Anyone has (had) similar issues and a hint on how to overcome the problem?

Many thanks in advance for help.
by
Solved: My provider had to activate 5G on the data-SIM-card, which was not set as default, strangely enough. (Telia Sweden). Now both 4G and 5G indicator led are green.

Exactly the same happens to me. Any solution so far?

2 Answers

0 votes
by

For me it is working,if it is set to Auto and Auto APN. Never tried 5G only.

     I have also static IP so I use internetip as APN and default password and username like my operator requires for it. 

      It also connects to 4G if I choose 4G only.

Only thing which is strange for me is this: https://community.teltonika-networks.com/55250/rutx-50-sinr-negative-value-antennas-connection

Best,

L

by
Thanks for your response.

I wanted to force 5G with "5G only" as it only connects with 4G also if I chose "Auto" as Service Mode.

All above with "Auto APN" setting BTW (I did not change that, as on my mobile 5G also works with this setting for the SIM cards).
0 votes
by

Hello,

It would be very helpful, if attached a troubleshoot file to your question from the device. Please, replicate the issue, then access router's WebUI, go to System -> Administration > Troubleshoot section and download troubleshoot file from there. 

However, based on your description, similar issue has already been reported and is currently being worked on.

Best regards,

by
Sorry - I cannot post that here due to privacy reasons. Any official Teltonika email address to send the troubleshoot file too?

In addition, please consider the syslog in my first post.
by

Attached files are private and visible only to Teltonika Moderators.

You can also send it in a private message, I will check it, and, if necessary, forward to the development team.

The troubleshoot file contains other logs, as well as device specific details and configuration, which are important in evaluating the issue.