FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
219 views 2 comments
by anonymous
I have a RUT956 running RUT9M_R_00.07.02.7 and am trying to verify whether it has modem connectivity or not. After a fresh setup (factory reset and new basic/advanced setup applied several times) the modem reports to be connected and reports having an IP address - but if I try to get this verified by e.g. pinging (System\Admin\Troubleshoot\Diagnostics) or updating the package list there are no replies. So I seem to be stuck at stis stage (I want to set up a Modbus RTU master and push data through MQTT). Does anyone see a clue in the attached log, or have any suggestions from previous experience?

PS. The SIM-card is a data only (no public IP) that has been verified to work using another 4G modem.
by anonymous
FYI:

Having fiddled with the advanced setup of the modem interface (setting it to force connection and adding a custom dns 8.8.8.8) I was able to refresh the package list and download 1 package...BUT only once (!).

After that refreshing stopped working, I cannot retrieve any packages etc...Going back and forth with the same advanced settings does not do anything either.

1 Answer

0 votes
by anonymous

Hello,

Based on the logs your device performs a successful data connection, but then gets disconnected. 

Could you enquire your ISP if internet.ventelo.no is the correct APN value, or try disable Auto APN in Network -> Interfaces mobile interface settings and simply set an empty Custom APN field?

Otherwise, I would like you to perform a modem module firmware update. For instructions, check this thread. Your modem ID is 1-1.4, latest firmware: SLM750_VE_4_0_17.

Best regards,

by anonymous
Updated the modem firmware, and tried with an empty APN field....

Got it to run for a short period could download to opkg packages, then tried pinging which failed and then it stopped working again..

If only things were a bit more plug and play :-O