subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
154 views 1 comments
by anonymous

Hi all,

We've been using (RUT950) the legacy FW 06.08.5 for about a year and it mostly runs ok with some cellular disconnections every now and then, solved by power cycling the router. The main settings/functionalities are pretty simple (nothing fancy):
- Custom APN
- Interfaces: Prioritise WLAN over Mobile
- Use of 3G+4G
- Monitoring via JSON-RPC, Modbus (persistence), and MQTT.

The last few weeks we've been trying to upgrade the FW and make use of the latest 07.02.7 but it give us a lot of issues when testing (and tried to replicate the same configuration):
- Monitoring via JSON-RPC had to change the username from root to admin (as mentioned in JSON-RPC issue)
- 4G connection drops every few seconds/minutes - this is the most worrying
- The whole web interface freezes and access is not possible (even when the security feature to block IPs after x failed attempts is disabled)
- JSON-RPC (via the py3 requests module) is failing 9 out of 10 times, with a timeout error. I've tried to increase  the timeout from 0.5sec to 1.5sec with no luck. Note that we periodically request from the router for reads (~ 10 secs).  

I don't know whether the new FW is too slow that causes all these issues or it needs a different configuration etc. 
Note Tested on FW 6.09.2 for a few hours and seems to be working as expected (similar to the 06.08.5).

Is there any setting or file that I can look at (maybe add some prints or something) to check: i) the 4G connection and why the interface shows as disabled when connection is lost and ii) similar with the JSON-RPC (like a file where sleep() or a condition has been used that cause these timeouts?

Many thanks!

1 Answer

0 votes
by anonymous


Thank you for the detailed description of the issue.

As a starting point, I would like you to attach a troubleshoot file to your question. Please, replicate the issue with the latest firmware, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. 

Best regards,

by anonymous
Thanks! I have to stick with the legacy FW for a few weeks and test it on the devices before starting again with the latest FW.