FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12006 questions

14286 answers

22526 comments

35868 members

0 votes
40 views 5 comments
by

Hi,
I've disabled my WebUI (HTTP) access via the WebUI itself, and now I want to start it back up.
I still have SSH access, so I'm not locked out.
I tried looking in `/etc/config/uhttpd` to see a setting to start it, but it didn't work.
Any way to start the WebUI via SSH?

The `main` part of the config is:

config uhttpd 'main'

option home '/www'

option rfc1918_filter '1'

option max_requests '3'

option max_connections '100'

option cert '/etc/uhttpd.crt'

option key '/etc/uhttpd.key'

option cgi_prefix '/cgi-bin'

option script_timeout '600'

option network_timeout '30'

option http_keepalive '1'

option tcp_keepalive '1'

option ubus_prefix '/ubus'

option no_dirlists '1'

option index_page 'cgi-bin/index'

option error_page '/404.html

option _httpWanAccess '1'

option enable_http '1'

Thanks

1 Answer

0 votes
by
In SSH, after saving the config file try to execute :

      /etc/init.d/uhttpd restart

If restart is not an option try:

      /etc/init.d/uhttpd stop

      /etc/init.d/uhttpd start
by
This didn't enable the WebUI for me
by

Any error?

Was the option enable_http '1' a 0 before editing the config file?

Just downvoting is not very kind when trying to help out.

I can't see the listening addresses, but you have not told what fw version you are on.

by

list listen_http '0.0.0.0:80'

list listen_http '[::]:80'

list listen_https '0.0.0.0:443'

list listen_https '[::]:443'

by
sorry about the downvote, did not mean any unkindness with it, just that it didn't work for me.
The enable_http option was indeed '0' before I started.

I managed to factory reset the device and this re-enabled the WebUI.

Thank you for trying to help.
by
OK.

If I where you I will try to write down the configuration file just in case it happens again.

If you just need it, the default configuration is stored in /etc/profiles/default.tar.gz

If you downbload the file with SCP and open it you will find the default configuration for uhttpd in /etc/config/uhttpd

You can copy any missing lines from there to the current configuration and you won't have to reset it to factory.