FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12615 questions

14984 answers

23965 comments

46773 members

0 votes
52 views 2 comments
by
Hello,

I can't see the hostnames of IOS devices at all? Is there a restriction? The names are all in the same format like the MACOS one. E.G. Frank-IPhone or Frank-IPad.

Any Idea?

Thank you in Advance

Frank

I've done the stuff. I couldn't restart the router so I tried to pick up the point of time. I switched the WLAN from the Iphone off at 16.38 h and on again at 16.39. The IP Address after the new connect 172.16.3.71, I hope it helps.

I've sent the file per mail. for 1Minute it generated 19 MB which I can't attach here
by
Thank you for the file.

Would it be possible to also get a TCP dump file?

2 Answers

0 votes
by

Hello,

I have performed some local testing with an iPad.

Please check, if you have Private WiFi address option set in your apple device's WiFi settings related to RUTX access point.

When it is set, Hostname option is not transmitted in the DHCP header during DHCP exchange. 

With this setting disabled, your iOS device hostname is included in the packets and gets resolved by the router.

This seems to be a measure to reduce the amount of tracking of iOS devices across different wireless networks. 

Best answer
by
Thank you. That solved the problem.
0 votes
by

Hello,

I would like you to attach a troubleshoot file. 

Please, replicate the issue first. The best way to do it would be to restart the router and simply connect those devices, so that DHCP exchanges would appear in the logs.

Then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. 

Another helpful thing would be a packet capture file, containing the same DHCP exchanges. For this you would need to download TCPdump from Services -> Package manager, then, as previously, go to System -> Administration -> Troubleshoot section and enable TCP dump for WLAN interface, used by iOS devices. Download the capture file after connecting some iOS device to the router. 

Attach the files by editing your question.

Best regards,