subscribe to our Youtube


13340 questions

15854 answers


50335 members

0 votes
125 views 0 comments

I have several RUT240s that we are trialling some SIMs with static IPs in for a telco.

The telcos other stahdard SIMs work fine, but the static IP SIMs show that they are registered on the network, on 4G, but the data is disconnected.

It doesnt make a difference if the RUT240 is running the legacy 1.14.5 firmware or the latest 7.02.7 firmware.

If we put the same SIMs into an RUT360 or RUTX11s we have, it works fine, which leads me to wonder if there is a newer modem firmware for the RUT240?

The current modems are running modem firmware EC25AUFAR02A04M4G; is there a newer one I can try?

1 Answer

0 votes

OK, so I've updated the modem firmware, which fixed the problem, and now answered my own question; should have researched a bit more. But for anyone else looking....

Found this answer, which worked out well for the RUT240 EXCEPT you use <ID> of 1-1, and I used modem firmware EC25AUFAR06A06M4G_01.002.01.002:

This part of the instructions have been corrected for my RUT240:

The last command will list available firmware versions. Next modify the following command:

  • modem_updater -i <ID> -v <VERSION>
    • <ID> - should be 1-1, however, in case of an error you should be shown a correct ID.
    • <VERSION> - enter the latest firmware version from the list of the previously executed command, it should be EC25AUFAR06A06M4G_01.002.01.002.
Note that it took about 45 minutes to complete the firmware update, and you MUST be on firmware (this didnt work on the legacy firmware, as the modem updater isnt an available package). I also had the modem on a wired WAN connection, which worked fine.

Best answer