subscribe to our Youtube


14170 questions

16819 answers


54138 members

0 votes
160 views 2 comments

Hi guys,

a RUTX11 has to act as WLAN/WIFI client at a existing WLAN infrastructure. The only topic is, to get internet access to the routers LAN (mostly to enable a ZeroTier VPN bridged to eth0). So, the WIFI connection is just used as WAN.

Unfortunately, the connection isnt stable. At some time (this can be 10 minutes or 5 hours), the connection breaks and doesnt come up itself. A reload of network helps.

I read lot also here at the forum, at OpenWRT forums and so on, tested different WLANs at different locations - but nothing to helps, it seems to be an internal or configuration topic.

Here is our setup and creation script, hopefully someone sees a mistake or error there or has some hints for us:


  • RUTX11, Firmware RUTX_R_00.07.02.7
  • 5GHz WIFI Client with WPA2 PSK

Creation script:

uci set'DE'

uci set'DE'

uci delete [email protected][1]

uci delete [email protected][0]

uci set wireless.radio0.disabled='1'

uci rename network.$(uci add network interface)=wwan

uci set network.wwan.proto='dhcp'

uci commit network

uci rename wireless.$(uci add wireless wifi-iface)=wsta_wifi

uci set wireless.wsta_wifi.device='radio1'

uci set wireless.wsta_wifi.encryption='psk2'

uci set wireless.wsta_wifi.ssid='mywifi'

uci set wireless.wsta_wifi.key='supersecret'

uci set'wwan'

uci set wireless.wsta_wifi.mode='sta'

uci set [email protected][1].network="$(uci get [email protected][1].network) wwan"

uci commit


Edit: added troubleshoot file

2 Answers

0 votes


Could you please attach a troubleshoot file to your question? Replicate the issue and then generate the troubleshoot file. The file can be downloaded from System -> Administration -> Troubleshoot page. Thank you.

Kind Regards,


Added file add question post.


The configuration looks fine regarding wireless settings. Also, I have tried these settings (script) and the wifi connection has been stable for a few hours now. The router reconnects to the AP after disconnects/reboots.

It seems that the troubleshoot file did not contain any logs regarding wifi disconnects/reconnects. Is it possible for you to generate a new troubleshoot file after the issue occurs? Also, what is your topology?

Did you try to manually set cipher to force CCMP (AES) in the Network -> Wireless -> Wireless interface -> Wireless security?

You can also try changing the operating frequency (channels and widths) in global 5GHz settings (just above your wireless interface). 

Kind Regards,


0 votes

I tried an additional complete new installation according my script and now it works surprisingly since three weeks. Also an upgrade of firmware to 7.0.3 didnt make problems.

So: fortunately it works, unfortunately I dont know what the problem is/was, which will affect me sometimes in future again, I guess.

Thanks a lot for your input!

The question can be closed.