FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
304 views 8 comments
by anonymous
I have enabled the SNMP service in V2C mode but am unable to get a response to any requests.  e.g. 1.3.6.1.4.1.48690.1.1.0.

Looking at tcpdump I can see the request is being received by the router but there is no reply.

The public community is set up with an address of 0.0.0.0 and ip mask of 0.

I can see the service is running when doing a ps | grep snmp.  I have tried stopping and restarting the service but it stills doesn't work.

I am running version 7.02.7.

Where am I going wrong?

Thanks,

Barry

1 Answer

0 votes
by anonymous

Hello,

  

Thank you for reaching out!

I've tested SNMP v2c with RUTX_R_00.07.03 and everything seems to be working as expected. However, there don't seem to be any issues reported with RUTX_R_00.07.02.7 either.

Can you make sure, that:

  • Your MIB browser supports MIB v2c;
  • Enable SNMP service toggle is turned on;
  • SNMP v2c Mode toggle is enabled;
  • The correct MIB file is in use;
Also, could you let me know what application you're using to access the router? I've tested it with iReasoning MIB Browser and all of the data is received after clicking on the "Advanced" button near the address bar and selecting SNMP version as 2.

Awaiting your response!

  

Best regards,
DaumantasG 

Best answer
by anonymous
Thank you for the suggestions.  I have done all the above before lodging the support request.  I too am using iReasoning MIB Browser set up as you suggested.  I have also tried using Paessler SNMP tester with no success.

The strange thing is I can get it to work with SNMP V3.
by anonymous

Attached are some screen shots of settings and the tcpdump from both the Paessler and the iReasoning queries using both V1 and V2,  In this instance they are using a community id of "Public" but I have also tried with "public" and "PRTG".  I have also tried using a spefic IP address which didn't work either.

14:32:51.822611 IP (tos 0x0, ttl 128, id 34171, offset 0, flags [none], proto UDP (17), length 72)                                                            

    192.168.1.142.65019 > 192.168.1.1.161: [udp sum ok]  { SNMPv2c C="Public" { GetRequest(29) R=24775  .1.3.6.1.4.1.48690.1.1.0 } }                          

14:33:52.348669 IP (tos 0x0, ttl 128, id 34805, offset 0, flags [none], proto UDP (17), length 74)                                                            

    192.168.1.142.55572 > 192.168.1.1.161: [udp sum ok]  { SNMPv2c C="Public" { GetRequest(31) R=826860628  .1.3.6.1.4.1.48690.1.1.0 } }                      

14:35:08.994325 IP (tos 0x0, ttl 128, id 35636, offset 0, flags [none], proto UDP (17), length 74)                                                            

    192.168.1.142.56827 > 192.168.1.1.161: [udp sum ok]  { SNMPv1 C="Public" { GetRequest(31) R=826860630  .1.3.6.1.4.1.48690.1.1.0 } }                       

    192.168.1.142.50076 > 192.168.1.1.161: [udp sum ok]  { SNMPv1 C="Public" { GetRequest(29) R=24776  .1.3.6.1.4.1.48690.1.1.0 } }

by anonymous

Hello,

  

I've re-tested it on my own setup, and I was able to verify, that the communication using SNMP v2c is indeed working:

Could you try updating to RUTX_R_00.07.03 and see if the issue still persists?

Just to clarify, both v1 and v2c do not work, only v3 works, correct?

  

Best regards,
DaumantasG

by anonymous
Hi,

I have been told that version 7.03 is unstable so am reluctant to upgrade at the moment.

Yes, neither v1 or v2c work but v3 does (when it's enabled).

Thanks,

Barry
by anonymous

Hello,

  

re-tested using RUTX_R_00.07.02.7, and everything works as well.

If the MIB file is correct, I'd recommend performing a factory reset and seeing if that helps. Perhaps the configuration files were corrupted during an update from an older version.

If that does not help, please attach a TCPdump file to your original post, where the SNMP packets without a response would be visible. This file will only be visible to Teltonika moderators.

  

Best regards,
DaumantasG

by anonymous
Hi,

Thanks for the follow up.

What process should I follow when doing a factory reset to restore my static IP assignments?  Is it a matter of going into System>Backup and doing a "Restore to factory defaults" and then doing a "Restore from backup"?

What settings do you recommend for doing a TCP dump to minimise unwanted traffic information?  I assume you are referring to the one under System>Administration>Troubleshoot.  e.g should I set the host name and port?
by anonymous

Hello,

  

As for the first part of the question, while backup would be the ideal option, it may also contain corrupted configuration files, so if only static DHCP leases need to be transferred, then the best option would be to download the DHCP config file using WinSCP. The file can be found by navigating to /etc/config/ and it will be simply named dhcp. Download the file, double-check that all of the leases are in place, and perform a factory reset. After the reset, reconfigure everything on the router and replace the dhcp file using WinSCP. Reboot the router and your devices should have their respective assigned IP addresses.

As for TCPdump, that is correct, it can be generated by navigating to System → Administration → Troubleshoot. The best way to filter the information would be to:

  • Select the interface as eth0 (if wired LAN is used, radio.network if WiFi is used);
  • Protocol filtering should be left to all;
  • Direction: Incoming/Outgoing;
  • Host: your PC IP address;
  • Port: empty;
  • Storage: RAM Memory.
Enable the TCP dump option, repeat the steps with SNMP, and after that download the TCP dump file.
If you'd like to remove any other information, the .pcap file can be opened in Wireshark, and SNMP protocol packets can be filtered out by typing snmp into the text field at the top and pressing enter. This will only display the SNMP packets. Then only the filtered packets can be saved by navigating to File → Export Specified Packets. The file can be attached to the original post (only visible to Teltonika moderators) or sent to me via a private message.

  

Awaiting your response!

Best regards,
DaumantasG 

by anonymous
Looks like the factory reset did the trick - a bit of mucking around to get everything back up and running but it worked.  SNMP V2c is now working.

Thank you for your assistance.

Barry