subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
206 views 4 comments
by anonymous

In the last few months I have had problems with theWLAN on a RUT240, the RUT was installedin february 2022 and has been running just fine until around november 2022...

When i log onto RMS the device status is "stopped", and in most cases it starts working again when i click off, and on again.

Also when i try to edit wifi i get error message.

1 Answer

0 votes
by anonymous


What is the firmware version of your device?

Have you noticed, if the interface stops after you reboot the router or in a random fashion?

If it is related to device reboots, I would like you to try the following. Login to the router's WebUI, navigate to System -> Custom scripts, and add the line below:

  • /etc/init.d/network restart

Best regards,

Best answer
by anonymous
The RUT240 is mounted on a vehicle, and as far as i know the problem occurs when the device is powered on. After i reset the WLAN, I dont think we have had any problems as long as the RUT is powered on.

Sometimes i have to reset the WLAN multiple times, sometimes I can see the device (Lenovo Tablet) is connected to the WLAN but it doesnt assign a IP adress, other times it doesnt connect to the wifi at all.

Firmware version

Firmware build date
2022-12-15 13:57:45
Internal modem firmware version
Kernel version
by anonymous

So the suggestion above should help. Add the line in a following way:

The solution is underway with 7.4 firmware release.

Another thing you could do for a while is to revert back to 7.2.7 firmware.

Apologies for the inconveniences.

Best regards,

by anonymous
The custom script worked. Do i need to remove the script when the fix with 7.4 firmware comes?
by anonymous


Solution was pushed to 7.03.3 firmware. I suggest to try it out. You can download it here

If you can afford to loose your current configuration, update with Keep settings disabled.

Best regards,