subscribe to our Youtube


13280 questions

15773 answers


50038 members

0 votes
33 views 4 comments
Hi there,

I have a running openVPN connection from an iMAC ( to my openVPN server on my RUTX11 ( From the client computer I can reach the server network. How can I reach the client network from the server network? I tried configuring a TLS client as mentioned in the openVPN section on the teltonika wiki, but I just cannot get it to work ( Does anybody have a step by step tutorial how to do this?

Thank you for helping!

1 Answer

0 votes


I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. 

The logs in the file might provide more insight into the issue.

Attached files are private and visible only to Teltonika Moderators.

Best regards,


I have now attached the file to my original question. I can reach the client from the server via the virtual IP, but as I said, I would like to reach it via the real client side IP and also the other machines in the client side lan.


There seems to be no routes in router's routing table to your local network. 

Your TLS client's configuration shows that client's virtual address is set as Could you change that to any pair from the screenshot below? and are usually taken by server by default. 

Also, logs show a recurring warning due to mismatch of auth option between devices:

  • WARNING: 'auth' is used inconsistently, local='auth [null-digest]', remote='auth SHA256'

Could you check if these settings match on both sides?

Best regards,


Dear Žygimantas,

unfortunately the teltonika community login was not working in the last 2 days. I have tried to setup the openvpn server using the rutx11 GUI, but unfortunately I a still stuck at the same point. I have atteched a screenshot of my congifuration in the GUI, the anonamized logfiles from my vpn client and the anonamized clinet.config to my original post. The CN of the client is karsten_ume. Can you have a look and tell me what I am missing here. What routes do I have to add in the rutx11 routing table (Interface, Target, IPv4-Netmask, IPv4-Gateway, Metric, MTU, Route type).

Thank you for your help!

Would it be possible to arrange a remote via Anydesk to try and configure your device to establish the tunnel?

Best regards,