FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
171 views 3 comments
by anonymous
We use both RUT240 and TRB245 in a private closed mobile network with no internet access, thus no access to NTP-server.

After upgrade from legacy to FW 00.07.02.7 (currently 7.03.1), the device time is always 22-12-20 or similar after each nightly reboot. With the legacy FW, the time was correct even after reboot. This means all logs are useless as the date/time is entirely wrong.

I tried to enable sync with mobile - does not seem to work, still wrong date/time.

How can I get the correct date/time in the devices after reboot?

1 Answer

0 votes
by anonymous

Hello,

  

There are a few options on what could be done in this case:

  • One of the devices could act as an NTP server with GPS synchronization:
    • As the TRB245 has a GPS receiver built-in, one of the devices could act as an NTP server. Since I presume all of the devices in the private network can reach each other, the single TRB245 device could provide time information for all of the devices in your private network.
    • NTP server can be configured by navigating to Services → NTP → NTP;
  • Option "Save time to flash" could be enabled:
    • This option will save the time to flash every synchronization cycle, thus it will not be lost after rebooting the device;
    • Please keep in mind, that if the update interval is quite frequent, this might cause premature Flash memory failure due to wear. By default, the update interval is set every 24h, and it is recommended to keep it this way if time setting will be written to flash.
Let me know if any more information is needed!

  

Best regards,
DaumantasG 

by anonymous
Thanks, that was a quick response!

Yes, we do have one RUT with a wired LAN connection in this network which does sync itself with an external NTP-server. I'll enable the NTP-server in this RUT and put its ip-address as the first NTP-server address in all the others, that should solve the problem. And a reboot every 24 hours should not wear out the flash.

Time synchronization could also be accomplished if the RUT could send an SMS to itself and then pick the time from the received SMS. Maybe something you could consider for future FW-releases :)

Best regards, /ChristerB
by anonymous

Hello,

  

While it could be accomplished, it is much more convenient and acurate to sync the time provided by the operator base station. I've tested it, and the Operator station synchronization option seems to be working. Perhaps the issues you're experiencing could be related to the private APN in use?

  

Best regards,
DaumantasG

by anonymous
I was a little bit mislead: The system overview page showed an old date/time, but when I look into the logfiles, the time seems to be correct. I changed the NTP to sync with operator on 21/3 (2 days ago) and the logs show correct date/time since then.

Maybe erroneous date/time in the overview page is due to the FW: RUT2_R_00.07.02.7.

I will upgrade to latest FW (07.03.03) later this week.

Thanks, and best regards,

/ChristerB