FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+2 votes
2,351 views 21 comments
by anonymous
Just tried to install my new RUTX50, but cannot get the 4G/5G-connection working with my provider KPN. I used my (working) datasimcard from my Ipad which gave the same result. Tried the manual settings for KPN, upgraded the firmware, but this doesn't help either. What is the solution for this problem?
by anonymous
Exactly the same issues here. Connection is stable when using just 4G, but thean there's almost no thruput of data.
by anonymous
Hello @EricJ,

Could you clarify if you are also based in the Netherlands?

If you're not, could you try blacklisting band n28 as per instructions described below and see if that helps?

Best regards,

DaumantasG

3 Answers

0 votes
by anonymous

Hello,

   

A fix was released to mitigate the issue regarding 5G band n28.

This fix requires the user to update the firmware of the built-in modem. There are a few prerequisites needed before the update procedure:

  • The modem needs to be stable. This means that for the update procedure, 5G should be disabled by navigating to Network → Mobile → General page;
  • Make sure the modem is not disconnecting by opening the CLI of the router (System → CLI), logging in with the username root and the same password as the WebUI, and running this command:

ping 1.1.1.1 -I qmimux0

  • And you should see the ping packets successfully making a round-trip:

  • If you see anything else than successfully sent packets, please try removing the SIM card completely before going forward with the update;
  • You will also need to check the modem firmware present on the device. To do so, in the CLI run the command gsmctl -y. If the output is one of these options:
    • RG501QEUAAR12A06M4G_04.001.04.001
    • RG501QEUAAR12A07M4G_04.001.04.001
    • RG501QEUAAR12A07M4G_04.200.04.200
  • If your modem firmware version is different, don't worry, there is another way. Please contact me directly via a private message with your firmware version and I will provide the alternative instructions. Please keep in mind that for the alternative instructions, an external WAN source will be needed (wired WAN, WiFi STA, etc.).
  • To begin the procedure, run the command

dfota -u

  • The procedure might take up to 10 minutes (or even longer depending on the connection speed), and after it's done in the CLI you should see a message Update script done!

5G can then be enabled and the functionality of the n28 band can be tested.

Please contact me directly via private message if you are experiencing any difficulties!

We apologize to anyone who experienced any issues due to this firmware bug.

EDIT: For TRB500 users, we ask you to wait until the release of v7.5 of RutOS. The modems within these devices use different firmware, which is still in the testing phase.

  

Best regards,
DaumantasG

Best answer
by anonymous
HINT / Question: Could it be possible that KPN is imposing IMEI number restrictions / validations? [ie KPN is promoting its own hardware..]. TMOB is applying this restriction in the USA to control == SELL the connected modems.

Is the RUTX+KPN problem now solved pls?

We are in the market to buy several RUTX s

kind regards,
interwood
by anonymous
Hello,

  

The issue was not only with KPN but was rather related to the transmitters used for the n28 band in the 5G spectrum. The modem update seems to have addressed the issue, as users who have updated the modem do not report any further issues.

As for imposing IMEI restrictions, that should not be the case, as RUTX50 is certified to work in the entire EU.

However, it should be kept in mind, that RUTX50 is only intended for the European market and will not work in the US.

  

Best regards,
DaumantasG
by anonymous
could you advise what firmware files i need to proceed with this please?
by anonymous
Hello,

  

No firmware files are needed, only a stable internet connection. The command dfota -u will download everything needed.

  

Best regards,
DaumantasG
by anonymous
thank you for this, i have successfully complete the update now it shows RG501QEUAAR12A08M4G_04.200.04.200 - Modem Firmware Version, However its not picking up 5G anymore.... did i miss a step ?
by anonymous

The issue for @BUFFBOY was solved here.

by anonymous

I have the same problems with T-mobile,
so I tried to do the update both via 4g and a stable WAN connection but both fail:



root@RUTX50:~# dfota -u
Preparing for gsm.modem0 update!
Searching for updates...
Connection error to FOTA server! ErrorCode: 169
No update found!
sed: /etc/crontabs/root: No such file or directory
Update script done!
root@RUTX50:~#

Please advise..

by anonymous
Hello,

 

Please make sure you are using the latest firmware, then replicate the issue, navigate to System → Administration → Troubleshoot,  and generate a troubleshoot file. Send this file to me via a private message and I will take a look. Thank you!

  

Best regards,
DaumantasG
+1 vote
by anonymous

Hello,

   

Just to clarify, the iPad also does not connect to the carrier? In this case, this would most likely be the issue on the operator's side or a damaged SIM card. Also, does the device not connect to the carrier at all? Or just the 5G connection is not established?

However, if it does work on the iPad, then there are a few troubleshooting steps:

  • Try setting the router to 4G + 5G mode. This is needed for 5G NSA operation;
  • Set the APN to internet;
  • Make sure the antennas are screwed in properly;
If none of these steps help, I'd like you to replicate the issue, navigate to System → Administration → Troubleshoot and generate a troubleshoot file. It can be attached to the original question and will only be visible to Teltonika moderators.

  

Best regards,
DaumantasG 

by anonymous
Both sim-cards work fine on 5G in the iPad. Tried the other settings that you suggested, but still the device does not make contact with 4G/5G. After applying the settings the device sometimes loses contact with the internal modem.

I attached the troubleshooting file to the original question. Can you help me out?
by anonymous
Hello,

  

The issue has been forwarded to our RnD department. I will contact you via private message if anything else will be needed.

Could also clarify if you are using the included PSU?

Thank you for your patience!

  

Best regards,
DaumantasG
by anonymous
I am using the included PSU

By the way. I just tried a normal SIM-card from both Dutch carriers KPN and TELE2 and they both worked fine in the RUTX50. The SIM-card I want to use in the RUTX50 is a special data-simcard which has 12 digits in stead of 10. Maybe that's the problem?
by anonymous
Thank you! I've relayed the information to our RnD.

I'll let you know once we have a solution.

  

Best regards,
DaumantasG
by anonymous
I succesfully excluded the 28-band from the list of bands of both the LTE as the 5G-settings. The RUTX50 now connects to the Internet using 4G.

You mentioned that KPN is the bottleneck in this issue, because they only use the 28-band for 5G. I am currently reviewing my mobile contract. Which are the Dutch providers that I can select to use 5G on my RUTX50?
by anonymous

Hello,

  

T-Mobile seems to also be using the n28 5G band, which has not been reported to cause any issues, so that should work fine. No n78 coverage seems to be available at the moment in the Netherlands.

As for KPN, many engineers are looking for a solution, so hopefully, it will get resolved soon.

EDIT: The T-Mobile n28 band seems to also have issues.
  

Best regards,
DaumantasG

by anonymous

Thank you for your patience! pikashow

0 votes
by anonymous
I'm also based in the Netherlands. FWIW not any RUTX50 will work withe datasims from the biggest provider in NL.

It bothers me big time since the RUTX50 is not for free and I also invested in a expensive antennasystem. Since there is obviously a fundamental problem which can only be solved by Teltonika.
by anonymous
Hello,

  

Beta firmware from the modem manufacturer is already being tested. I will inform you when we have more news and the firmware.

We apologize for any inconvenience caused.

  

Best regards,
DaumantasG
by anonymous
Considering buying the Rutx50, but also based in the Netherlands. Any progress on this issue? Or should I consider another brand?
by anonymous

I downloaded and tried the latest update for the RUTX50: 2023.04.18 but this is not the solution for the KPN datasim. My system should be used in my mobile home. Maybe it works ok in France and Spain?

by anonymous
Hello,

Currently, this issue is only known to affect T-Mobile and KPN operators in the Netherlands, and only on the n28 band. There currently is no fix as of yet, but I will inform you once it's available.

Best regards,
DaumantasG