FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
465 views 6 comments
by anonymous
Dears,

Kindly requested to support me։

What parameters need to be set on the TRB142 to read data from the electrical meter via Optoport?

Connection diagram is following:

Comm. server/PC--> TRB142 (4G, over IP)-->RS232 to OPtoport Cable -> Optoport on El. meter (ABB type meter).

I want to note that when I use the scheme Comm. server/ PC--> TRB142 (4G, over IP)-->RS232 to RS485 adapter ->RS485 interface on El. meter (ABB type meter), then everything is OK, the connection and data exchange are set without problems.

Looking forward to your reply.

1 Answer

0 votes
by anonymous

Hello,

  

Generally, such adapters are not really supported by us, unless they can output standard RS232 data. In this case, the adapter might work, but we definitely cannot guarantee it. It is recommended to use the RS485 port if it is available.

Could you provide a URL to the cable you purchased? I'd like to find more information on your particular device to check what could be the issue. Some of these adapters I found to mention a specific baud rate.

What kind of data are you reading from the device? Is it Modbus? Perhaps you could try the Serial-over-IP feature (or this) to check if any data is flowing in?

Also as I understand, these devices are powered by the RS232 interface, is that correct? Or do they have an external power source?

  

Best regards,
DaumantasG

by anonymous

Dear DaumantasG,

Below are the answers and additional comments:

The commercial and technical parameters of the electrical network are read from the meter.

I myself do not know what Modbus, but all meters have a RS-485 interface and an optoport for reading data using DLMS protocol.

See below the URL of the RS -232 to Optoport, through internet (baud rate 300 - 9600):

http://www.metekco.com/xcart/metertest-opto-optical-port-reader.html.

Plus, most probably the mentioned devices are powered by the RS232 interface, since these device (com to optoport cable) do not have an external power. source.

Waiting your response.

by anonymous

Hello,

  

Could you try enabling the "Raw mode" option in the Serial over IP configuration?

If that does not help, please try disabling the Over IP function (and other services, which are using the RS232 port), log in to the device using the CLI/SSH, and run this command:

cat /dev/rs232

If you see data coming in, we can continue troubleshooting the issue. However, if nothing happens when the command is run, then most likely this device will not work with TRB142.

    

Best regards,
DaumantasG

by anonymous

Dear DaumantasG,

In response to your comments kindly requested to support me with these two issues below:

1. I didn't find and where the rel. tab to set "Raw modeyou specified above in order to make relevant changes. Please note FW VER: TRB1420_R_00.01.05. Where exactly I can make rel. change.

2.  I cannot log in to device using the he CLI/SSH, to be precise, in command  prompt: ( ssh admin@192.168.2.1)  enter  then (admin@192.168.2.1's passwords) entering right password produce (Permission denied, please try again please), although the entered password is correct.

Moreover, after  successfull login in to device (by the same password) using browser and follow the rel. tab/window http://192.168.2.1/cgi-bin/luci/admin/services/cli  -and try to login then again it says that the entered password is incorrect.

Waiting your response.

by anonymous

Hello,

  

  1. Please update to the latest firmware (TRB1_R_00.07.04), as the version you're using is quite outdated. The Raw mode will be found in the Services → Serial Utilities → Over IP menu, in your created instance configuration.
  2. SSH can be reached by logging in with username root instead of admin. Admin is reserved for the WebUI, while root is used in the shell. The password will be the same as for the WebUI.

  

Best regards,
DaumantasG 

by anonymous

Dear DaumantasG,

Please be informed that the latest FW TRB1_R_00.07.04   is implemented successfully.

And all the recommendations and commands (cat /dev/rs232) that were given by you above and were carried out, but without result.

What other commands can be given to make sure again?

A completely different question: for communication, we use a SIM card from an operator with a static IP. If the ability to use a usual internet SIM card from the operator? But at the same time, when the modem is turned off and on at the far end (besides to the electr. meter), then the IP will change and it will be impossible to provide communication without knowing the IP. Is it possible, taking into account the latest version, to set parameters, for example, to make a connection by MAC address? If possible, please describe in detail what parameters need to be set on the modem in order to implement a connection to the modem.

Thank you in advance.

Waiting your response.

by anonymous

Hello,

  

If no communication is visible when running the command I provided, then it's highly likely that it will not work with our device, and a copper communication medium will need to be used with the device.

As for your other question, perhaps you mean that the IP address is public and not static? Carriers often provide devices with a dynamic public IP, meaning that the device can be reached from the internet, but every time the connection is disconnected, the IP address changes. In this case, we have a service called DDNS. The router updates its public IP address every few minutes, thus you'll always be able to reach the device, even when the IP address changes. More information and a configuration example for one of the DDNS services can be found here.

Let me know if you have any additional questions!

  

Best regards,
DaumantasG