FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
256 views 4 comments
by anonymous

Hello,

I have been using the Modbus TCP Slave for quite some time now. Since I upgraded from firmware version RUT9_R_00.07.02.4 to the latest one: RUT9_R_00.07.04, I have issues with the Modbus TCP Slave and actually only with the register address 137 "Digital galvanically isolated input (DIN2) state" which is not updated anymore... 

I tested this on two other RUT955 routers that I also upgraded to the latest firmware version and still the same issue. I precise that I don't seem to have the same issue with other registers; I can still write on register 201 "Galvanically isolated open collector output status" and read 201 "Galvanically isolated open collector output status".

Finally, after upgrading to the latest firmware version, which is unfortunately not usable for me, I downgraded to the following:

RUT9_R_00.07.04 -> Not OK !

RUT9_R_00.07.03.3 -> Not OK !

RUT9_R_00.07.03 -> Not OK !

RUT9_R_00.07.02.7 -> OK !

RUT9_R_00.07.02.4 -> OK !

Therefore, it seems like something is wrong since the RUT9_R_00.07.03 version... (again, that was tested on three routers with the same behavior). 

Could you please investigate this and tell me if I missed something.

Best regards,

2 Answers

0 votes
by anonymous

Hello,

A similar issue regarding digital non-isolated input state on 4-pin connector has been reported here.

The developers are aware about it.

Solution (including DIN2 as well) is set to be released in the upcoming 7.04.1 firmware update. 

At the moment staying on 7.2.7 is suggested.

Apologies for the inconveniences.

Best regards,

by anonymous
Hello,

Thanks for the answer. Any idea when the 7.04.1 firmware update will be available ?

Best,
by anonymous
I cannot give specific dates, but current timeline is around the end of this or the beginning of the next month.

Best regards,
0 votes
by anonymous
Hello,

I have seen that a new firmware version, RUT9_R_00.07.04.1, was released.

According to the changelog nothing related to this issue is fixed, right ?

Thanks for answering.

Best,
by anonymous
Hello,

The solution was pushed to 7.04.2 firmware.

Best regards,
by anonymous
Hello,

Could you please confirm that this issue was fixed with RUT9_R_00.07.04.2 ?

Best,