subscribe to our Youtube


14081 questions

16725 answers


53723 members

0 votes
97 views 9 comments

Device: RUTX14
Firmware: RUTX_R_00.07.04 (however the problem has been around for over a year)
Internal modem firmware version: EG12EAPAR01A09M4G_01.001.01.001
Kernel version: 5.4.229



So i have been trying to tinker with different settings for a year now trying to make this work. Been trying different solutions provided in the forums for the problem, manual APN, port settings, nightly reboots, using 2.4GHz / 5GHz wifi etc. None seem to have solved the issue.


  • RUTX14 only working as a modem, only 1 sim card on the primary slot, mobile on NAT-mode, basically all other functions have been disabled, just some flood/attack protection enabled
  • Linked to RUTX14 there is only the firewall, lan-interface over static IP 
  • AP connected to firewall

Only the modem (RUTX14) crashes during the Mikrosoft Teams call and sometimes during Google Hangouts, at least having difficulties to keep up, a lot of stuttering. The crash is pretty much instant, you can see from the logs, at least from the system-log that the meeting in the logs starts at 11:00 local time and the crash occurs at 11:02. Currently joining calls over mobile hotspot, since cannot rely on the modem itself.


1 Answer

+1 vote


I would like you to perform a modem module firmware update and see if that helps to solve the issue.

For instructions, please refer to one of the previous threads in this link. 

Best regards,

Best answer
I will try this approach, thank you

Okay, was able to try updating via SSH. However it seems that the modem_updater execution runs into some problems since the modem firmware is never updated.

Any advice?

[email protected]:~# modem_updater -g
[INFO] Detected modem_n: 0
Modem List:
[0] Quectel EG12-EA | USB_ID: 1-1 | Firmware: EG12EAPAR01A09M4G_01.001.01.001 | builtin:true
Available versions:
[email protected]:~# modem_updater -i 1-1 -v EG12EAPAR01A13M4G_01.001.01.001
[INFO]found modem_n: 0
[000.000]: Version: QFirehose_Linux_Android_V1.4.11
[000.001]: Builded: Mar  3 2023 13:20:49
[000.002]: P: /dev/bus/usb/001/003 idVendor=2c7c idProduct=0512
[000.002]: C: /dev/bus/usb/001/003 bNumInterfaces: 5
[000.002]: I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff
[000.003]: E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms
[000.003]: E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms
[000.004]: I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.004]: E: Ad=83 Atr=03 MxPS= 10 Ivl=9ms
[000.004]: E: Ad=82 Atr=02 MxPS= 512 Ivl=0ms
[000.005]: E: Ad=02 Atr=02 MxPS= 512 Ivl=0ms
[000.005]: I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.005]: E: Ad=85 Atr=03 MxPS= 10 Ivl=9ms
[000.006]: E: Ad=84 Atr=02 MxPS= 512 Ivl=0ms
[000.006]: E: Ad=03 Atr=02 MxPS= 512 Ivl=0ms
[000.006]: I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.007]: E: Ad=87 Atr=03 MxPS= 10 Ivl=9ms
[000.007]: E: Ad=86 Atr=02 MxPS= 512 Ivl=0ms
[000.007]: E: Ad=04 Atr=02 MxPS= 512 Ivl=0ms
[000.008]: I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff
[000.008]: tmp=/sys/bus/usb/devices/usb1/../driver, driver=../../../../../../bus/platform/drivers/xhci-hcd
[000.009]: qusb_noblock_open port_name = /dev/ttyUSB0
[000.013]: old software version: EG12EAPAR01A09M4G
[001.014]: poll_wait events=POLLIN msec=1000 timeout
[001.015]: switch to 'Emergency download mode'
[001.017]: successful, wait module reboot
ping: sendto: Network unreachable
[ERROR] internet connection is not active
curl: (6) Could not resolve host:
cat: can't open '/tmp/known_hosts': No such file or directory
[ERROR] firmware directory is empty. Mount failed? Exiting...
[INFO] restarting modem 0
[INFO] Starting services:


SSHFS also seems to be missing from the GUI, over SSH all seems fine:

[email protected]:~# sshfs -V
SSHFS version 3.7.1
FUSE library version 3.10.1
using FUSE kernel interface version 7.31
fusermount3 version: 3.10.1


Another option would be manual update, however the link you have provided on the other thread:

If alternative WAN source is not available, use the following instructions:

  • Download the firmware zip from this link.

Points to a file ( that is not found from the modem_updater -g -output. Is there a link to the newer version available, perhaps local update is required?


ping: sendto: Network unreachable

Do you have the router connected to a wired WAN source, as it appears that device does not have internet connectivity?

Keep in mind that modem becomes unavailable during the update, thus it needs a different internet source.

Alternatively, have you tried downloading the firmware zip and updating it locally?

Edit: Try EG12EAPAR01A12M4G, as it has helped to solve the same issue as well.

Best regards,


Keep in mind that modem becomes unavailable during the update, thus it needs a different internet source.

It seems like i have misunderstood the instructions, will try with other WAN for internet connection during the update.

Provided another WAN point to the modem by connecting to mobile hotspot. However the ISP had blocked port 22, had to reroute traffic using VPN. This worked and the update via SSH was successful.

Now internal modem firmware version is upgraded to "EG12EAPAR01A13M4G_01.001.01.001". Will have to test in a meeting how it functions.

I shall return back to this thread once tested!
Glad you have managed to perform the update.

Please return with the feedback, hopefully positive one, for reference, in case other users encountered the same issue.

Best regards,

This fix worked for me, thank you ZygimantasBliu. Took a while to gather reliable test data, but everything seems to be running very smooth now.

A few takeaways from updating using the modem_updater function:

  1. internal modem firmware update disables your sim card, establish an alternative connection for example using cellphone as mobile hotspot and connect rut router to this wifi accesspoint
  2. Using cellphone as hotspot might be limited by your ISP, since the update needs SSH access with port 22 open and these are most often not open for cell phone plans, circumvent this with a reliable VPN on cellphone
  3. Using SSH is simple, for windows use PuTTY, for linux use ssh -- remember to connect to [email protected] -p 22 (root, not username)

Additional notes:

  1. For some reason firewall dropped the default gateway a few hours after the update, might not be in any way related. However, if LAN disconnects after the update, check first the firewall default gateway
  2. Not so sure if this only applies to device firmware updates, but just to be safe if something is not working after the update, perform a factory reset and do the router setup anew.


Update process

Access your device via SSH and execute the following commands:

  1.     opkg update
  2.     opkg install modem_updater
  3.     opkg install sshfs
  4.     modem_updater -g (this spits out the ID and the available VERSIONs)
  5.     modem_updater -i <ID> -v <VERSION>