subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
800 views 8 comments
by anonymous

 noticed a slow connection for my SIM card,tried everything to change with help from the forum. The last step was to update the modem firmware (EG06ELAR04A04M4G). 

  • opkg update
  • opkg install modem_updater
  • opkg install sshfs
  • modem_updater -g

I got the following error message after the line: opkg install sshfs

root@Teltonika-RUT360:~# opkg install sshfs

Installing sshfs (3.7.1-1) to root...

Package installation encountered an error, removing previously installed packages.

Collected errors:

 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.143-1-79c5dc6db69102eb2943a96b9bec8b63) for kmod-fuse

 * opkg_download_pkg: Package sshfs is not available from any configured src.

 * opkg_install_pkg: Failed to download sshfs. Perhaps you need to run 'opkg update'?

I have a WAN failover conection is active and I have Internet.

opkg update gives the message that he cannot find the vuci packages. These files do not exist on the downloads/ site

 How to solve this issue?

1 Answer

0 votes
by anonymous


The opkg error message about missing repository can be ignored, as it does not exist anymore. 

As for the sshfs package, what firmware version does your device have installed?

The package should also be available in router's package manager (Services -> Package manager -> Packages), or can be downloaded from here, and uploaded to the router.

Otherwise, I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Attached files are private and visible only to Teltonika Moderators.

Best regards,

by anonymous

I could not install the sshfs package either. I tried via the Package manager but it is still unavailable. I also tried it via opkg install sshfs and I got some errors.Via the download link and the package installer I could install the sshfs package and now it is installed. Do I need to enable it?

My firmware is: RUT36X_R_00.07.04 with kernel 5.4.229.

After changing some settings my Internet connection was down and does not came up again. Also after reboorting no INternet anymore. A fully reset was the solution and now I can update. Almost no errors. 

Only a question;I see some brick items when upgrading the modem. Is this a real risk? I am very depend of my RUT360.

I like to go over to the latest but not the Beta version. Is there a change list available?

root@Teltonika-RUT360:~# modem_updater -g

[INFO] Detected modem_n: 0

Modem List:

[0] Quectel EG06-E | USB_ID: 1-1 | Firmware: EG06ELAR04A04M4G | builtin:true

Available versions:






Is the command to update: modem_updater -i1-1 -vEG06ELAR04A08M4G

by anonymous

The correct command is:

  • modem_updater -i 1-1 -v EG06ELAR04A08M4G

with spaces between options -v and -i and their values.

There is a possibility that the update might fail, though, if you have stable internet connection and reliable power supply, it should be fine.

Could you tell the reason, why do you need updating the modem firmware? 

Best regards,

by anonymous
Thanks for the quick reply. I use the modem in Italy and last time I had very slow Internet connection. Comparing to my phone (forced to 4G)  it was really slow. I tried different settings with the APN and so on, but no result. The last thing I could find is the update for the modem.

I only can update in The Netherlands because there I have fiber Internet. In Italy I only have 4G.
by anonymous

Remote update is not recommended.

What signal metrics does the router show in Status -> Network -> Mobile? How do they compare to the reference values (here)?

Does it use dual carrier aggregation?

Could you try locking different LTE bands for the router to use? For instructions refer to this video.

Best regards,

by anonymous
Thanks for the additional information. I will check the values. This weekend I will go to Italy for 14 days of work. I will check all the values and the signal strength. But I think if my phone is much faster than the RUT360  with the standard antenna's there is something wrong.

I already tried to lock the LTE band but no luck. I do not use dual carrier aggregation.

I had the feeling that the RUT360 is faster after the complete reset with firmware version 7.04. Internet via the WAN port is definitely faster after the complete reset. My WAN cannot be the bottleneck with more than 1 Gb/s.

I will let you know later. Thanks for your help. Best regards.
by anonymous

At this moment I am in Italy and hereby the signal strenghts. I hope you can help me to get a higher better speed.With my phone (forced to 4G) at the same location I reach about 20 Mb/s.


by anonymous

RSRP value seems to be on the lower side. You could try a different device placement, or, if possible, a directional antenna.

If you are using an Android phone, you could download an app called LTE discovery from app store. It would allow to check the band your phone uses and signal metrics it senses for comparison reasons.

This could, for example, allow to set the same LTE band(s) on the router, if the one(s) it uses differ.

Then, you have to take into account that there is most likely a difference in the capabilities of the modems between the router and your smartphone, as the latter probably has a more powerful hardware capable of advanced signal processing features, compared to RUT360. 

Best regards,

by anonymous
I updated the modem succesfully and bought a directional MIMO antenna. Very soon I will be back in the rural of Italy and I wil test again if I have a better performance.

During the last visit the cell phone companies did all update their systems. With my phone I have a 140 Mb/s connection now.

I will keep you informed.

Best regards.