10922 questions

13024 answers

20290 comments

27201 members

0 votes
3,785 views 12 comments
by
If yes, is there some RUT240 specific things to consider before I try to do it?

Which are my options to recover if I would accidentally brick it by installing unsupported firmware? Is there a JTAG interface on the device which I can use to reset to factory defaults?

Has anyone done it?

I need newer NodeJS and after few weeks I still haven't managed to compile it on RutOS's GPL version, or upgrade RutOS GPL version packages to newer dependencies required by NodeJS (especially newer libc).  Specifically I just need the SSH console, the mobile network and the ethernet to work and the system to run NodeJS v8 or newer. (I don't even need LUCI.)
by
Have you got a copy of this if you wouldn't mind sharing or how you do it?
by

I indeed did magaged to get 18.04 running with the help from the only answer, but 18.04 was missing most of the kernel patches, and I haven't had time to port them to the newer kernel yet. Eg. mobile broadband for example doesn't work yet. I also had to disable most features to free enough space for NodeJS; it's not running even LUCI anymore. (Not problem for me, since I'm going to manage it through NodeJS app.) I don't have any patches available at this moment.

by
It's a shame they don't keep it updated with the latest kernel and patches and not v15 of OpenWRT dated back to 2016. All I want to run is Wireguard VPN but it wasn't available back then. Unfortunately looks like I'm going have to return them and go back to raspberry pi or something.
by
Ok but the links you got in the answer are no longer accessible.

Do you mind sharing the patch to get 18.06 running  even if everything is not working?

By the way the manufacturer teltonika should be ashamed of doing there own little fork of openwrt, instead of collaborating with the community so that there device is officially supported. It's in the interest of nobody, including them.
by
I succeeded in running official openwrt on the board but wifi is not working because I don't have the right dts file.

Can you provide the dts file you use?

https://forum.openwrt.org/t/getting-rut240-to-work/46868
by
Hello,

Wireguard will be added to all Teltonika's devices which have package manager 2020 may.
by
Hi,

WireGuard is going to be released with the new RutOS firmware tomorrow.

EB.

1 Answer

0 votes
by
Hello,

yes, its possible.

Nothing specific. You can recover over bootloader.

There is a patch for openwrt master branch. You can port it to 18.06

https://we.tl/t-0ZirZDZNcg
Best answer
by
Thank you! The patch helped, too.

I guess I have configured some settings in the configuration about hardware wrong. I got "Invalid image, hardware ID mismatch, hw:32200002, image:35000001". Which are correct hardware settings for 32200002?

Looking at OpenWRT source, 0x32200002 matched with tiny-tp-link and 35000001 with generic.
by
It's just ID, you can change it to 0x32200002.

To use sysupgrade you need to add:

TPLINK_HWID := 0x32200002

REVISION := RUT2xx

IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs |\
    pad-rootfs | teltonika-fw-fake-checksum | append-string RUT200019999 | append-string master |\
    append-md5sum-bin | check-size $$$$(IMAGE_SIZE)

To flash firmware via webui will be much harder, take a look to fw_validate.sh
by

Here is my edited patch and attempt to flash a firmware built with it: https://gist.github.com/jheusala/3d06e501cffdd5986b8f16732854f808

It gives an error "Invalid image, not supported on this device."

I didn't know where that "REVISION := RUT2xx" should have been put. 

by
Try this one, dont forget to flash openwrt-ar71xx-generic-rut200-squashfs-factory.bin not sysupgrade.

define Device/rut200
  DEVICE_TITLE := Teltonika RUT200
  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -uboot-envtools
  BOARDNAME := RUT200
  SUPPORTED_DEVICES := rut200
  IMAGE_SIZE := 15552k
  MTDPARTS := spi0.0:128k(u-boot)ro,64k(config)ro,64k(art)ro,15552k(firmware),576k(event-log)ro
  TPLINK_HWID := 0x32200002
  TPLINK_HWREV := 0x1
  TPLINK_HEADER_VERSION := 1
  CONSOLE := ttyATH0,115200
  REVISION := RUT2xx
  KERNEL := kernel-bin | patch-cmdline | lzma | tplink-v1-header
  KERNEL_INITRAMFS := kernel-bin | patch-cmdline | lzma | uImage lzma
  IMAGES := sysupgrade.bin factory.bin
  IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs |\
    pad-rootfs | teltonika-fw-fake-checksum | append-string RUT200019999 | append-string master |\
    append-md5sum-bin | check-size $$$$(IMAGE_SIZE)
  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
    append-rootfs | pad-rootfs | append-metadata |\
    check-size $$$$(IMAGE_SIZE)
endef
TARGET_DEVICES += rut200
by

Thank you! It works now. 

Although sysupgrade command gave some errors while it was running.

  • "sh: 0: unknown operand" 
  • "/lib/ledblink.sh: line 24: can't create /sys/class/leds/status_green/brightness: nonexistent directory"
  • and after flashing: "Appending jffs2 data from /tmp/sysupgrade.tgz to firmware...TRX header not found Error fixing up TRX header"

Anyway, my RUT240 is running now OpenWRT and node. It barely fit into the space, I had to remove LUCI completely to free enough memory. Node OpenWRT package takes over 5 MB; I'll need to start to optimize that next :)