subscribe to our Youtube


14081 questions

16725 answers


53723 members

0 votes
68 views 7 comments
Good afternoon,
One of our router RUT240 cannot reach the mobile network.
When I  try to set the mob1s1a1, it tells the internal modem is blocked or disabled (please find enclosed the screenshot).
What is going on ? (I reset to factory default twice).
Thank you very much,
Have a good day,

1 Answer

0 votes


It appears to be modem hardware issue.

I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. 

The logs in the file might provide more insight into the issue.

Could you also login to the router via SSH and post the output of the command:

  • ls /dev

Best regards,

I reached out the mobile network again.
the troubleshoot report indicates :
"time":1679903489,"id":6952,"text":"Port speed for port LAN1 changed to 100 baseT",
"time":1679903494,"id":6953,"text":"Port link state of port LAN1 changed to DOWN"
"time":1679903495,"id":6954,"text":"Port link state of port LAN1 changed to UP"
Seems LAN port goes on and on with no particular reason.
I cannot attach the trouble shoot file.
Thank you !
You can send the troubleshoot file in a private message.

Did the mobile just start working, or did you make any particular changes?

In regards to the LAN port state change, could it be related to faulty cable? Does the wired connection work properly?

Best regards,
Thank you for the return. I just factory reset a third time and it started working after I entered my own APN. Though it seems to reach and lost the mobile network very currently. Has it something to do with the LAN cable ?
I send you the events log and the troubleshoot in MP. Thank you !

The LAN1 port link state changes come from the ESP device connected to the port, as it continuously initiates DHCP requests. 

Could you try giving it a static lease, which can be done in the router's WebUI Network -> Interfaces -> Static leases page. Another option to try is to enable Force option in Network -> Interfaces -> [lan_interface] -> DHCP server -> Advanced settings.

Regarding mobile, within the first 15 minutes the troubleshoot has logged in, no mobile disconnects have occurred. However, there is a following warning coming from Auto reboot application: Can't wget URL. 

What, I assume, happens is that after 5 such failed attempts, device is rebooted. The reason being that option, which might have been accepted in previous version, is not supported now and needs to be modified to

I also see that you have failover enabled, which appears to be unnecessary, as you are only using mobile interface and no wired WAN is connected.

In general, based on the configuration, I assume that you have updated your device from legacy firmware with Keep settings option enabled. My suggestion, to avoid any possible issues related to incorrect migration between firmwares, would be to reset the device to factory default settings and reconfigure it.

Best regards, 

Thank you.
I already set a static lease for the esp device, though enable Force in Advanced settings of DHCP server can be done at the same time ?
Also, I disabled the wget ping and disabled the failover.
It seems LAN1 port state change continues. Could be it because of a weak cable ? But in what way that would disconnect the router from mobile network ?
Thank you very much !


Did disabling wget ping and failover stop mobile disconnection issues, or are they still present?

Regarding LAN1 port state changes a cable might be the issue, but it does not explain continuous DHCP exchanges less than every 10 seconds, as the router is configured to issue a lease for 12 hours.  

Have you tried connecting a different device to LAN1 port to check, if the same behavior repeats?

Do you have any logs from ESP side, what do they tell?

Best regards,

Sorry about my belated answer.
Disabling wget ping and failover stopped mobile disconnection issues.
Thank you very much for the help provided !
Have a good day !