FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
562 views 5 comments
by anonymous

Hello,
we have a setup similar to this.

Access to devices behind the RUT240 is via OpenVPN through port forwarding.

Unfortunately, this does not work with the RUT955.

What else needs to be set on the RUT955?
 

7 Answers

0 votes
by anonymous

Hello,

  

Are you able to reach the device using its OpenVPN tunnel IP address? Is RUT955 the OpenVPN server or a client?

I'd like you to attach a troubleshoot file, as it contains your configuration and logs. A troubleshoot file can be generated by navigating to System → Administration → Troubleshoot and the file can be attached to the original post. This file will only be visible to Teltonika moderators. One thing you could do is configure the TLS connection on the server and then push the routes to the client. This way you will be able to reach the LAN device by using its LAN IP address. More information about OpenVPN configuration can be found here.

  

Best regards,
DaumantasG

0 votes
by anonymous
Hello,
the connection via the VPN tunnel works. The RUT955 can be reached via it. The RUT955 is the client.

How can I send the Troubleshoot file here?
by anonymous

Hello,

The original question can be edited to attach the file, or you can send it to me via a private message by clicking "Send private message" button here.

Best regards,
DaumantasG

by anonymous
Hello,

  

At least from the first look, nothing seems to be out of the ordinary with the OpenVPN configuration. However, I noticed that your ARP table is empty, meaning the device with the IP address 192.168.0.105 is either disconnected or offline. You could also try pinging the device from the router CLI by navigating to System → CLI or simply SSH'ing into the router.

Let me know how that goes.

  

Best regards,
DaumantasG
0 votes
by anonymous

Hello,
the ping to 192.168.0.105 works.

0 votes
by anonymous

The packets arrive in the LAN of the RUT955.
It's just that no reply comes back.
I think the firewall does not allow packets from the LAN from 192.168.0.105 to 10.1.3.44.

by anonymous
Hello,

Machine seems connected to RUT LAN : OK

Is Support Center PC able to ping RUT LAN IP : ?

Is Firewall set to allow from ovpn to Lan ?
0 votes
by anonymous

Hello

Is Support Center PC able to ping RUT LAN IP : ?

no, the Support Centre PC cannot do this.
It can only ping the RUT955 via the VPN tunnel.

Is Firewall set to allow from ovpn to Lan ?

Yes, LAN is allowed everywhere

by anonymous
Hello,

Please try changing the OpenVPN zone forward flag to Allow.

Best regards,
DaumantasG
0 votes
by anonymous

Hello,
do you mean like this

That does not help. We had already tested it before writing here.

by anonymous
Hello,

Please try resetting the device to factory defaults and reconfiguring it from the scratch, as I'm not sure what could be causing the issues here. If you updated the device, it could be that the configuration did not transfer through correctly.

If that does not help, we might need to organize a remote session for further troubleshooting. Contact me via private message if this will be needed.

Best regards,
DaumantasG
0 votes
by anonymous

Hello,
with NAT rules it works.

FTP does not work.

I don't want NAT either. With the RUT240 it works without it.