subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
203 views 3 comments
by anonymous

Hello, I am looking for help with an RUT241 router and VPN access.

My RUT241 is currently in FW RUT2M_R_00.07.04. I want to link my RUT241 OpenVPN client to the LAN port, to communicate remotely on devices connected to this LAN port. I relied on the "OpenVPN traffic split" page.

Unfortunately, when I want to run the "opkg update" command line, the CLI gives me several error messages "Failed to download the package liste from ...openwrt....gz".


root@Teltonika-RUT241:~# opkg update


*** Failed to download the package list from



I cannot download any installation package, yet my router is connected to the internet. I then tried to manually download these packages from the internet link and manually install them on the router, but that doesn't work either. So I can't do my VPN routing.
Does anyone know how do I bind my LAN interface to my VPN client?
Thank you for your help and send you my best regards.

1 Answer

0 votes
by anonymous


I would like to review your configuration. There should be no issues to update repositories or upload files.

Could you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Also, could you specify, what happens, when you upload a downloaded package? Is it for correct mipsel_24kc architecture?

The vpn-policy-routing package for RUT241 can be downloaded from here.

Best regards,

by anonymous

Hello and thank you for your answer.

You will find the troubleshoot file in my original post. For information, I did the following manipulations before downloading it. I first tried to install the packages from the CLI. I then downloaded manually corresponding to this link

This file is also attached in the first message. I finally tried to upload the vpn-policy-routing package according to your download link. Every time I want to upload a package from the WebUI (Service -> Package Manager -> Upload), I get the error message "Package installation failed".

How to check if it is mipsel_24kc architecture?

Thank you for your help and send you my best regards.

by anonymous

Let's try a different approach. 

Download WinSCP, open this application, login to your device as instructed here. Move the vpn-policy-routing file I have referenced in my previous comment to your router's /tmp directory. Then login to the router via SSH and execute the following command:

  • opkg install /tmp/vpn-policy-routing_0.3.4-8_all.ipk

If the command fails, could you try resetting your device to factory default settings and reconfiguring it again?

Best regards,

by anonymous

Thanks for your help. I was presumably able to install the vpn-policy-routing with this method. I then continued the instructions explained on the "OpenVPN traffic split" page. However, I have an error after the execution of the last command (uci commit).

The error tells me

vpn-policy-routing 0.3.4-8 monitoring interfaces: wan VPN [✓]
vpn-policy-routing 0.3.4-8 started with gateways:
WARNING: The 'ignore' target is used by a policy 'blank', but a WebUI setting to show 'ignore' target (webui_show_ignore_target) is disabled!

Is it a problem?

You can find a new troubleshot on my original post.

Best regards