subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
77 views 1 comments
by anonymous

Hello all,

I am using RUT950 in motor home to access a digital IP-webbased HMI remotely. The HMI is already accessable locally by

I created a Remote Access in Teltonika's "RMS Connect" by given the local IP and Port 80 for HTTP. The status shows me, that the device is reachable. I created a connection and the given URL start communication.

Here, it is half-working, because I see the black background loading and the wait-symbol is loading, but the rest of visualization is not loading. From supplier I got the info, that the websocket needs additional Port 3000.

I tried to open that port, but it still not work. I am not so experienced in IP port forwarding. Maybe it is just a beginners fault. ^^ Is somebody sees the issue?

Here are the settings:

Name Protocol Source Via Destination Enable Sort

Port 3000


From any host in wan

To any router IP at port 3000

Forward to IP, port 3000 in wan

Is there a difference by using LAN or WLAN? I use WLAN to connect RUT950 to Internet and I use WLAN as hotspot for my digital IP-webbased HMI to connect to RUT950.

The websocket also gives me an error prompt:

Unhandled promise rejection: , 
"stack":"Error: Failed to construct 'WebSocket': An insecure WebSocket connection may not be initiated from a page loaded over HTTPS.\n 
at Y._createNewWebSocket (\n 
at Y.connect (\n 
at Object.<anonymous> (\n 
at (<anonymous>)\n 
at o ("

Thanks for any hint.

FW version: RUT9XX_R_00.06.08.3

1 Answer

0 votes
by anonymous



RMS Connect will not work in this case, as it uses a single port for communication.

You will need to use RMS VPN Hub, add the router, and push the routes to reach the LAN network of the router.

We have a configuration example here on how to set it up.

Your "Routes" tab of the VPN Hub should look like so:

Except the IP should be changed to the LAN IP of the RUT950 ( with subnet mask in your case). Make sure to enable the LAN forwarding on the device in question.


Best regards,

Best answer
by anonymous
Hello Daumantas,

good news. with VPN connection it works.

Many thanks for support!

best regards, Danilo