FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
314 views 7 comments
by anonymous
Have an RUTX50 on latest firmware 07.04.2 with a Gamma static IP data SIM as a backup WAN for our Netgate pfsense box. In NAT mode all works fine and can generally get most things working but would ideally like to have the public IP directly on the Netgate. Have followed the bridge mode example and Netgate recieves the public IP but no traffic can either reach or be sent from it. I'm raising this with Gamma and Netgate as well as I suspect it may be an issue there but since I've seen similar posts on here around Bridge mode not always working thought would check here as well...

1 Answer

+1 vote
by anonymous

Hello,

    

Since the Netgate device receives the IP address, I have some doubts about the issue being on the RUTX50, as most of the router features are disabled when running in this mode.

To eliminate the Netgate device from the equation, try plugging the RUTX50 directly into your PC and check if it received an IP address and the traffic can flow through.

If everything works as intended on the PC, I'd start checking the Netgate device. Perhaps something is misconfigured in the firewall zone that the RUTX50 is in?

If, however, it does not work on the PC as well, a few things to make sure of:

  • I assume this is already ruled out, but make sure the DNS servers are set correctly;
  • Make sure only one device is plugged into the RUTX50 at the same time when in Bridge mode (managed switches included);
  • Try entering the MAC address of the Netgate device interface that the RUTX50 is plugged into when configuring Bridge mode on the RUTX50;
  • Try using Passthrough mode with/without DHCP to check if anything changes;

    

Best regards,
DaumantasG
by anonymous

Sorry, just found out, that this issue may be related to the RUTX50 in particular.

Please try downgrading to v7.4.1 and check if the issue is still present. This firmware can be downloaded here.

There will be a fix provided for this issue in v7.4.3 which should be released in the following weeks.

  

Best regards,
DaumantasG

by anonymous
Rather than create a new post, I had discovered a similar issue since upgrading to v07.04.2 on my RUTX50. However it looks like Teltonika are aware and a fix is due in the next update, great news. I'll post my findings here anyway for anyone else having a similar issue who also may be looking for a solution...

I also run my RUTX50 in passthrough mode (UK Vodafone, Data Only SIM) to a non-Teltonika managed router, and on Firmware v07.04.1 all was functioning as expected. I backed up my configuration settings and updated the Firmware to v07.04.2 and with the exact same configuration settings applied, was not seeing traffic 'south' of the RUTX50. I could see the expected Vodafone IP settings and signal strengths, all as per usual, and could even perform a speed test using the WebUI within the RUTX50. But no internet on the connected devices after this, no Google, BBC, Netflix, etc.

After calming the family down about the 5mins lack of internet, I changed from 'Passthrough' to 'NAT' mode on the RUTX50, applied the settings, and everything sprang back into life as before with internet traffic passing, all be it with a couple of double NAT warnings. I went back to 'Passthrough' mode, even tried DHCP on and off (normally off), but still the same issue of no traffic, which is when I found this post and as per DaumantasG's suggestion, rolled back to Firmware v07.04.1, and everything works again in 'Passthrough'.

I've now downloaded this Firmware & my backups settings locally as a 'known working' configuration for the future...

Hopefully someone else finds this post useful, and thanks again DaumantasG for the fix and danjeman for the descriptive post!

Kind Regards, OGBB.
by anonymous

Hello,

  

RutOS v7.4.3 has just been released and will soon be available for download from our Wiki page here.

Thank you, everyone, for your patience.

  

Best regards,
DaumantasG

by anonymous
Thanks DaumantasG,

I'll get it installed sometime over the weekend and tested with my configuration.

Although, I also noticed that the RUTX50 changelog looks to have been accidentally cleared/deleted from the Wiki page.

Kind Regards, OGBB.
by anonymous

Hello,

We will be awaiting your feedback.

The changelog seems to be available on the downloads page, and I've highlighted the bridge mode issue:

Best regards,
DaumantasG

by anonymous
Just updated firmware and bridge mode does now work. Thanks
by anonymous
Glad to hear that!