subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
141 views 3 comments
by anonymous

I have a problem sometimes where a device (RUTX11) becomes disconnected in RMS. It shows up with the red dot, even though WAN and Mobile connections are fully working, and DNS working fine as well.

Going to Services > Cloud > RMS indicates no problem, shows "connected" even though the device is not accessible via RMS.

Is there a way to check RMS connection status from CLI or JSON-RPC?

I know about ubus call rms get_status but in some cases it shows no error but still RMS shows it disconnected.

Usually, running /etc/init.d/rms_mqtt restart gets the connection working again.

So my idea was to periodically check RMS connection and auto restart mqtt if necessary. But not sure how to really check the status. Is there a log somewhere, or some SSL handshake that can be tested?

Is there a better way??

1 Answer

0 votes
by anonymous


The command:

  • ubus call rms get_status | grep status

should return a value of 0 in case the router is connected to RMS and a 1, if not, along with error codes and explanatory texts. 

If it does not display any errors, from the router's perspective, it is connected to RMS. I also doubt, if any logs are given in such cases.

Since I have not experienced a similar situation, you can try stopping rms process in the router by /etc/init.d/rms_mqtt stop and running it in debug mode with rms_mqtt -d &, to see, if anything shows up.

I would also like to note, that there were some issues with RMS recently, a more major one had occurred during the weekend, which resulted in some devices not being able to come up online in the system. It has now been resolved, and devices should be reconnecting back to the system correctly. 

In your case, are there any devices at the moment, that are still not connecting back to RMS? Could you send their serial numbers in a private message?

Best regards,

by anonymous
Ok. I guess it was an issue with RMS on server side, because the command returned 0 in my case. After restarting rms_mqtt, the status turned green and the device was reconnected. I will track it with -d debug flag next time it happens.
by anonymous


I just experienced this problem again, 2 devices went offline in RMS due to primary WAN (eth1) failing, they were in failover mode to 4G LTE, which lasted around 10 minutes. Devices stayed online and everything was functioning normally - BUT, RMS never came back online. It stayed red until I bounced the rms_mqtt service with .

I ran rms_mqtt -d on one of the devices and saved the output, is it useful? I can send it via private message. I hope this behavior will be improved, it is troublesome to lose RMS access every time a device experiences a momentary WAN loss.

by anonymous
I have just sent a private message @ZygimantasBliu