FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
357 views 2 comments
by anonymous
I have 3 Teltonika RUT955 devices which all have problems with the current firmware. I have tested 07.04.3 and 07.04.2.

As soon as the LTE modem is under load by, for example, a speed test (Ookla), the modem seems to crash. The speedtest is then interrupted. It is then no longer possible to connect to the Internet. A few seconds later the RUT955 shows N/A everywhere in the modem status. A few seconds later I get the message "404 page not found - Your requested path: /status/network/mobile/1-1.4".

Then the following appears in dmesg:

[ 1295.614880] usb 1-1.4: USB disconnect, device number 7

[ 1295.620736] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0

[ 1295.629301] option 1-1.4:1.0: device disconnected

[ 1295.635022] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1

[ 1295.643578] option 1-1.4:1.1: device disconnected

[ 1295.696913] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2

[ 1295.705967] option 1-1.4:1.2: device disconnected

[ 1295.712168] option1 ttyUSB3: GSM modem (1-port) converter now disconnected from ttyUSB3

[ 1295.720589] option 1-1.4:1.3: device disconnected

[ 1295.726095] qmi_wwan 1-1.4:1.5 wwan0: unregister 'qmi_wwan' usb-1b000000.usb-1.4, WWAN/QMI device

A few seconds later, the overview of the modem status appears again and shows me values. Shortly after that I have a data connection again. If I then provoke the whole thing again by a speedtest, the whole thing starts again from the beginning.

As soon as I flash an older firmware on all 3 devices (07.02.7) this problem does not occur anymore. I have attached the troubleshoot file.

1 Answer

0 votes
by anonymous
Hello,

It seems that the modem module inside the router runs on a quite old firmware. I suggest to try updating it. I have provided you with instructions in a private message.

Best regards,
by anonymous
Thank you for your reply and the attached instructions. This means, that an update of the modem firmware is not performed with an update of the RUT firmware?

EDIT: The listing of the available firmware versions via modem_updater unfortunately fails with a timeout. ([ERROR] Timeout while mounting with sshfs) The download link of the firmware zip does not work either. Here it also comes to a timeout. I have just tried the download through several different providers.

EDIT2: I have just tried the whole thing again. The listing of the available versions was now successful. However, an update to the latest version .21 is not possible. It aborts with the message "retrieve prog nand firehose failed.". The version .20 could be flashed. I will try again later the update to the current RUT firmware.

EDIT3: I have just updated to the latest RUT firmware. With the modem version "SLM750_VE_4_0_20" the problem seems to be solved now. The modem no longer crashes under load. However, the latest modem firmware .21 can still not be flashed.
by anonymous
As long as the issue is resolved, no need to update further.

Best regards,