10925 questions

13028 answers

20304 comments

27348 members

+1 vote
1,877 views 9 comments
by
Hello,

I am trying to setup my RUTX09 with automatic SIM switch.

I have 2 4G mobile contracts with 80 GB data and I want to switch when the first one reaches 60GB.

Is there a way to setup automatic switching when the limit is reached and automatic reset of the data counters on a certain date

Thanks for your help

1 Answer

0 votes
by

Hello Maurice,

Ther is a function to switch SIM cards automatically on certain data limit, you can find it in:

Network > WAN > MOB1S1A1 (or MOB1S2A1) > SIM Switch:

Enable automatic switching and On Data Limit

Further down there is a section for Data Limit configuration

Set desired cap and save.

 

In further releases you should be able to set the exact date to clear data counters, but unfortunately, there's no such function right now.

by

Hi Peasant,

Thanks for your reply. I have the "On data limit" option on my RUTX09 but when I enable it, I don't get the "Mobile Data Limit" section but there is a warning message saying "Make sure you have enabled mobile data limit on one of this SIM card interfaces!". I did not find any place where to enable mobile data limit on the SIM card interface. May be there is a CLI command but I did not find any info on it.

by

What firmware version are you using? I'm using RUTX_R_00.01.06 and it is at a very bottom of the page .

by

I am using RUTX_R_00.01.06 too. I upgraded directly to this firmware after receiving the device.

Do you have a "data_limit" file in the /etc/config directory ?

by

That's strange. For me both options are present even after reset. Maybe you could try resetting the router?

There is no such file, these settings are saved in /etc/config/quota_limit

by

thanks for the info, that's strange to have same firmware, different behavior. Did you have other firmware installed before RUTX_R_00.01.06 ?

Can you please send me the content of your /etc/config/quota_limit file. May be I can activate the feature by loading the file from the CLI interface.

by
Sure, here you go.

root@Teltonika-RUTX09:/etc/config# cat quota_limit

config interface 'mob1s1a1'
        option enabled '1'
        option data_limit '60000'
        option restart '1'
        option enable_warning '0'
        option sim '1'
        option modem '3-1'

config interface 'mob1s2a1'

It is a router for testing purposes, so it gets it's firmware reflashed quite often.

Maybe you could try refreshing browser with clean cache (CTRL-F5) or incognito mode?
by
It worked, thank you very much for your help !

I added the 'mob1s1a1' config interface section in my quota_limit file and did a "luci-reload" and the "Mobile Data Limit" section appeared.

Now I have setup a low limit so I will check if the switch happen
by
I'm very glad to hear it worked. I'll let you know when upgraded firmware with day selection is ready. Good luck :)
by
Yes, please keep me updated on this feature.

I just saw the switching to sim2 as I reached the limit I fixed, so looks like it's working fine