10908 questions

12999 answers

20266 comments

26729 members

+1 vote
2,308 views 12 comments
by
I tried to make my RUT955 (FW ver.: RUT9XX_R_00.06.04.5) use LTE B8 as the preferred band, but after doing this and rebooting the router (because it will become unresponsive after saving changes, see https://community.teltonika-networks.com/9505/rut955-unresponsive-after-saving-changes ), it had connected to 3G WCDMA 2100 instead.

I know there is a mast with band 8, because thats the one it uses all day, but for some reason during evenings and some nights, it will switch to another mast using band 20, and I get terrible speed so I want to force it to use the "good" mast.
by

Hi. I have the same problem on router RUT950 with FW RUT9XX_R_00.06.04.5. In my area I get the speeds of 30-40 MBit/s on the LTE Band 3. And I normally get only around 8-15 MBit/s on the LTE Bands 7 and 8. These tests are done on both RUT950 and other router model (E5186 Huawei). If I try to set 4G only and Manual as connection type and Band 3- the router still selects different LTE bands in automatic mode and most often it selects Band 7 which has slightly stronger signal but much worse speed.

by
Hi, I have this issue too.

When i set network frequency band to LTE B3 instead it  uses WCDMA 900.

My router is also RUT955 and the FW is RUT9XX_R_00.06.04.
by

Is there something else you wanted?

It would also be great if it was possible to lock the connection to a Cell ID, and if was possible to log signal quality data to get a graph over time. Like the signal strength but with the good stuff like SINR etc.

by
Did you managed to get the band-lock to work?

Afterall i ended up using console-command to lock my modem to a desired band, at the moment it looks like my modem is staying in LTE band 3.
by
Nope, every time I try to lock to band 8, it switches to 3G instead.

Oh, there is a cli to lock to a band? Do you have a link to commands?
by

Hi, i used this manual http://autorata.com/files/LTE/TELTONIKA_RUT955_BANDLOCK_PROCEDURE.pdf

and here is same information from teltonika wiki https://wiki.teltonika.lt/view/LTE_band_lock

It worked for me but i advice you to take backups before you proceed.
by
I expected some kind of response from a Teltonika representative on this issue.
Have had this RUT955 since May 2019 and have had problems with poor speed (2-12Mbit)  and connection drops.
I have tried everything, two different antennas including a Poynting XPOL-2 MIMO directional antenna which greatly improved the signal quality but not the speed.

Bought myself a TP-Link MR600 just to make sure it was not the router that caused the problems I have had.
Right out of the box with the included antennas indoor, I got about 40 Mbits.
Changed it to use the Poynting antenna and got 65Mbit in the middle of the night, switched back to the Teltonika router, got about 16Mbit.

This will force me to switch to the TP-link router instead wich is sad because I liked all the features that comes with the RUT955.

The fact that you don't even answer this thread make me think twice before I look at your products again in the future.

2 Answers

0 votes
by
Hello,

Can you please provide a product code of the RUT955 you are using?
by

System
Router name RUT955
Host name Teltonika-RUT955.com
Router model Teltonika RUT955 LTE
Firmware version RUT9XX_R_00.06.04.5
Kernel version 3.18.44
Bootloader version 3.0.1
by
As for my router it is RUT950 UG12H0 with s/n: 1101535995.

FW: RUT9XX_R_00.06.04.5.

Kernel version: 3.18.44

Bootloader version: 3.0.1
by
I have the same issue with mine... Manual select falls back to WCDMA 2100, even if service mode is "4G (LTE) only" and only LTE bands are selected. "Force LTE network" is also "Enabled".

Firmware: RUT9XX_R_00.06.04.5
Kernel: 3.18.44
Bootloader: 3.2.1

Product Code: RUT955T03XXX
Batch number: 0068
Hardware revision: 1713

Modem model: EC25
FW version: EC25EUGAR06A03M4G
0 votes
by
I followed procedure and also got OK on the command gsmctl -A ’AT+QCFG="band",0,4,0,1 that should force use of Band 3. Nevertheless router still lives its own life and constantly selects Band 7, and only sometimes band 3 or 20. Of course I tried ”restarr connection” and also rebooted the whole router.
by
Hi,

After while this started to happen for me too!

If you want you can try downgrading your firmware, i have RUT9XX_R_00.06.03.2 installed and webui works as it should on that version.

You can find older firmwares here:

https://wiki.teltonika.lt/view/RUT9xx_Firmware
by

Thank for the advice Jesse! smiley

I now downgraded the FW on my RUT950 to version RUT9XX_R_00.06.03.2 and the Band Selection functionality finally works fine! I did not even have to do any tricks via CLI, It actually work via GUI interface (method=manual, then the set checkbox for the desired band). 

The only small problem - router erased all the configuration after downgrade. But that was expected since FW page informed about it (your uploaded FW is older version than existing, your settings will be removed. Are you sure to proceed?).

Now I am really happy setting the 4G band I want. Now I have more stable connection and much faster speed. 

Regards Ivan (bender)