10922 questions

13023 answers

20289 comments

27194 members

0 votes
1,618 views 3 comments
by
Hello,

im using my first Teltonika. I configured the "Client Mode" in the Wireless section.

Devices on LAN Interface are not able to connect through the Wireless Interface. The Wireless Interface is reachable. They are all in the same network.  How needs the LAN to be configured? Is there a need for a new route?

For my understanding, there are the right routes for the network, but i dont really understand the routing function in the new firmware.

2 Answers

0 votes
by
Hi,

Do you mean you are using WiFi WAN? If so what exactly doesn't work and what you want to make?

By the way, WiFi WAN and router lan should be in different subnets, for example if router LAN IP is 192.168.1.xxx then WiFi WAN IP should be for example 192.168.4.xxx.
by
Hi,

yes, this is what i want. I tried this with an RUT955 and with this it seems that the LAN Interface is "transparent". It is important, that they are in the same Subnet.
by
Seems you need Relayd option:https://wiki.teltonika.lt/view/Relayd

On RUTX it is still on development.
0 votes
by
Hi,

I struggled with this myself for a while. I setup everything according to "teltonika relayd" wiki page but wasn't able to access the RUTX10 in wifi client mode or any clients connected to it.

What I found is that the teltonika wiki page is not entirely accurate. It is necessary that RUTX10 in client mode has a lan ip address in a different subnet and you set lan gateway on your client router to the main wifi access point. Different subnet is needed in order for relayd to work correctly and won't be used by any of the clients - they will all be on the same subnet as the main wifi acess point. Also make sure to disable dchp server on the client wifi router and under lan interface enable relayd option with the configured wwan (wifi) interface - then it will work as expected.

Google "openwrt relayd" for more information.

Basically you will need to configure it like this

Router 1 (access point):

Ip: 192.168.1.1 /255.255.255.0

Dhcp enabled

Router 2 (Rutx10 in wifi client mode - select firewall zone as 'lan')

Ip: 192.168.2.1 / 255.255.255.0

Gateway: 192.168.1.1

Dhcp disabled

Relayd enabled (with wwan interface)

All your clients should now be in 192.168.1.1/24 subnet

Hope this helps.
by
Hi,

i have the same problem I want to use 2 RUTX10, one configured as Access Point and the other as client.

Both are on the same Lan 192.168.1.X/24

I tried this guide with 2 RUT240 :https://wiki.teltonika-networks.com/view/Relayd

And all works fine.

I'm trying to do the same on 2 RUTX10 but nothing works.

Any suggestion?