11384 questions

13559 answers

21243 comments

31871 members

0 votes
1,054 views 6 comments
by

As posted, have been waiting for a firmware update and hotspot capability however it doesn't work.

Error as below : 

Failed to execute arcombine dispatcher target for entry '/admin/services/hotspot/general'.
The called action terminated with an exception:
/usr/lib/lua/luci/util.lua:608: bad argument #2 to 'format' (string expected, got nil)
stack traceback:
	[C]: in function 'format'
	/usr/lib/lua/luci/util.lua:608: in function 'dbg'
	/usr/lib/lua/luci/model/network.lua:258: in function 'callback'
	/usr/lib/lua/luci/model/uci.lua:275: in function 'foreach'
	/usr/lib/lua/luci/model/network.lua:256: in function '_wifi_sid_by_wid'
	/usr/lib/lua/luci/model/network.lua:821: in function 'get_wifinet_by_wid'
	...b/lua/luci/model/cbi/chilli/coovachilli_overview.lua:62: in function 'create'
	/usr/lib/lua/luci/cbi.lua:1256: in function 'parse'
	/usr/lib/lua/luci/cbi.lua:251: in function 'parse'
	/usr/lib/lua/luci/cbi.lua:422: in function 'parse'
	/usr/lib/lua/luci/dispatcher.lua:884: in function 'target'
	/usr/lib/lua/luci/dispatcher.lua:1024: in function </usr/lib/lua/luci/dispatcher.lua:1020>


Issue replicated on multiple devices.
by
Hello;

I would like to know how setup my RUTX11 as hotspot. can you help me?

Thanks

1 Answer

+1 vote
by

Hello, I was not able to reproduce this error on RUTx11 2.0 firmware version. Could you please re-download firmware from https://wiki.teltonika.lt/view/RUTXxx_Firmware and re-flash it without Keep Settings, and see if situation changes?

by
Will do.  

I was probably going to try that later today - all X11's have so far been upgraded and settings kept.
by
OK, so a re-flash without keeping settings and i'm now able to configure hotspot.

However, have another issue now with OpenVPN.   Connection is configured and establishes when enabled however all traffic is blocked.  Looking at the firewall settings i cant see an OpenVPN interface so unable to add it to any zones to allow the traffic.
by
Hello,

it would best if you would create a new topic on this issue so others who are facing the same issue can look it up more easily.
by

Hello;

I'm new, I just buy a RUTX11, by default I only see a normal WIFI AP, but we need a Hotspot. is possible to configure a Hotspot for user control?

Do you have a procedure?

My version is: RUTX_R_00.01.04.5

I try to update to: RUTX_R_00.02.00.2 But after upgrade the Router do not reconize the SIM, we need to do a rollback.

This is for a Rural School. thanks in advance.

by
Hello, did you do a fresh upgrade to 2.00.2 without keeping previous settings? If not, I would strongly recommend upgrading without keeping settings or reset router to factory defaults after the upgrade.

Best Regards