8401 questions

9886 answers

15679 comments

14156 members

0 votes
894 views 3 comments
by
Hi,
I'd like to increase the CLI timeout because after less than a minute the connection timeout.
Is it possible ?
Thanks,
Gianluigi

2 Answers

0 votes
by

Hello, Gianluigi!

Could you tell me with which device exactly this is happening? What is the firmware? And also describe the connection method of the device that needs to access the CLI of the router.

Regards, Aliaksandr!

by

Hello Aliaksandr, this is the router main characteristics:

I usually select the CLI   (the one with the >_ symbol)

Then I login in the router using the root credentials , and then I connect by ssh to a LAN device

after less than a minute it disconnects me from the router.

Thanks,
Gianluigi

by

Hello, Gianluigi!

I took the same RUT950 device with the same firmware version. And I tried to carry out the same operations as you did. And everything works. 

CLI does not shut down in a minute. The only difference that I see is the device on the LAN that you are trying to connect to. 

I used another Teltonika router as a device on the LAN network. And everything works and does not turn off.

Perhaps your device has settings for remote access to CLI \ SSH, or settings for access time to SSH.

Regards, Aliaksandr!

by
Thanks Aliaksandr,
I perform some additional test without involving any LAN device but only with the Router., and these are the results:
Test with CLI access to RUT950 in Firefox
    1.    08:43 login
           08:57 still connected, so force CLI exit
    2.    09:13 login
           09:15 Session closed
    3.    09:16 login
           09:22 Session closed
    4.    09:23 login
           09:25 Session closed
    5.    09:26 restart CLI from RMS
           09:27 login
           09:28 Session closed
    6.    09:29 login
           09:35 still connected
           09:38 Session closed
    7.   10:36 login
          10:37 Session closed
    8.   10:38 login
          10:45 still connected - force CLI exit
    9.   10:46 login
          10:47 Session closed

As you can see the behaviour is quite unstable, if you could try to repeat the test with your router I think it could help to understand if the issue is only related to my router or is more general.
Thanks,
Gianluigi
0 votes
by
Hello,

The timeout value is now set to unlimited.