FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
2,861 views 12 comments
by anonymous
Hello,

We use rut 955 router, and gps has stop working on some of them (3 for now) after upgrade.

Reset, reflash bootloader, upgrade without keeping params has no effect.

Maps keep empty, and no coordinates are shown.

PS : Here's log i can see in system logs (i can see that only when there's a gps signal (antenna is outside), as soon as antenna is inside, no more warning logs)

Johan

Thu Oct 10 17:36:00 2019 daemon.warn gpsd: Error while handling a sentence

Thu Oct 10 17:36:01 2019 daemon.warn gpsd: Error while handling a sentence

Thu Oct 10 17:36:02 2019 daemon.warn gpsd: Error while handling a sentence

Thu Oct 10 17:36:03 2019 daemon.warn gpsd: Error while handling a sentence

Thu Oct 10 17:36:04 2019 daemon.warn gpsd: Error while handling a sentence

gpsctl -i -x

0.000000

0.000000
by anonymous

Hi,

I've same issue with my (old) RUT955 and latest firmware 06.08.5 ... so, I suppose this issue hasn't been fixed in versions after 06.00.4

Unfortunately, I have no access to the "Fix" as described in this ticket

Is it possible to give me access to this "Fix" please ?

Thanks !

3 Answers

0 votes
by anonymous

Hi,

Which FW version are you using? I just tested this with RUT9XX_R_00.06.04.5 and it seems to work fine. But maybe there's something with the configuration. Can you send me the router's Troubleshoot file via private message? It can be downloaded from the router's WebUI System → Administration → Troubleshoot page. Just be sure to download the file WHILE the issue is present (at the moment when GPS is enabled, antenna outside and the router can't get a fix).

0 votes
by anonymous
Same problem here with RUT955: In RUT9XX_R_00.06.00.4 GPS was working fine,

since then in all other version newer then RUT9XX_R_00.06.00.4 it stopped working.

Even in current version RUT9XX_R_00.06.05.1 it is not working.

I also tried to hard reset device and renew the configuration completely, unfortunately without any success.

Logfiles says the same: daemon.warn gpsd: "Error while handling a sentence"

Pls. see also here (as this issue has been discussed some time ago without a solution):

https://community.teltonika-networks.com/4946/gps-module-is-not-working-on-rut955-after-update-rut9xx_r_00
by anonymous
Hi,

This may seem silly, but I have no idea what's wrong since it works well on all versions for me, but have you attached the GPS antenna and placed it outside (not in a building)?

If yes and it still doesn't work, can you tell me the router's product code and modem's FW version? Both can be checked in the Status → Device page.
by anonymous
Yes of course, GPS antenna is connected and also placed outside.

When I downgrade to version RUT9XX_R_00.06.00.4
GPS is working fine again (I have reproduced this more than once now). I also tested this behaviour with ALL newer versions but RUT9XX_R_00.06.00.4 seems to be the last version GPS was working fine. As I already wrote above, this seems to happen more often also with other users (pls. see link I posted or google for this issue). Did the hardware or chipset change some time ago so that only older devices are affected?

Product Code is: RUT95517V020

Serial: 06957237

FW Version: 12.636.11.01.00

Model: ME909u-521

ME909u-521
by anonymous

Update:

I found out something additional: When I connect via putty to the RUT955 and use command cat /dev/gps I can see, that GPS data is being received by the device (pls. see screenshot.). But Web interface is still NOT showing any GPS position at all (pls. see 2nd screenshot).

Than after stopping process cat /dev/gps agagin and restarting gpsd, however, if I use command gpsctl -u to control the GPS status or gpsctl -a for GPS altitude, the result is always 0.000000

by anonymous
Ok, we think we know what this is. First off, you have a router with an older module which we produce anymore. The module's firmware was not equipped to deal with this year's GPS rollover.

Second, R&D is now working on creating a workaround that should fix the issue from the router's FW side.

I will inform of any future news that I receive.
by anonymous
Ah ok, an old module, that's exactly what I was assuming.

Looking forward to a workaround to get this fixed once. Thank you very much in advance!
by anonymous

Hi,

We'we prepared a fix. It's only a test FW version, to see if this fix solves the issue. You can download it from here. Any feedback is appreciated.

by anonymous
I did a first rough test and can confirm that it looks quite well, it seems to be working. Thank you very much!
0 votes
by anonymous
Sorry, i was a bit busy last weeks, but happy to hear you're looking for a solution.

And i confirm, mine is also a quite old router.
by anonymous

Hi,

We'we prepared a fix. It's only a test FW version, to see if this fix solves the issue. You can download it from here. Any feedback is appreciated.

by

Sorry for delay, gps is now working, great.

But fix time is not good. 

Time looks good, but not the date.

i've also this problem with others routers.

Fix time Latitude Longitude
2000-04-26 13:34:58 52.590834 10.064575

by
Édit : fix time is working, i've to  set router time once, and after i Can update time from gps and fix Time is ok.
by

Hello, when this will be push on public firmware, i've updated with the latest firmware available (RUT9XX_R_00.06.06.1), and gps isn't working on that firmware.