FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

11943 questions

14214 answers

22417 comments

35396 members

0 votes
922 views 1 comments
by
In the latest FW (00.01.11.1) for the RUT240 I have to following issue trying to use the Luasec module eg:

root@Teltonika:~# lua -lssl

lua: error loading module 'ssl.core' from file '/usr/lib/lua/ssl.so':

File not found

stack traceback:

[C]: ?

[C]: in function 'require'

/usr/lib/lua/ssl.lua:7: in main chunk

[C]: ?

[C]: ?

I crosschecked the md5sum of ssl.so, ssl.lua etc with the ones of FW version 01.07.1, they all seem the same.

The only difference that I see is the upgrade of the OpenSSL library to version libssl.so.1.1

Looking to the vanilla version of OpenWRT 19.07, is see that there is a specific patch for OpenSSL versions lower than libssl.so.1.1

https://github.com/openwrt/packages/blob/openwrt-19.07/lang/luasec/patches/040-openssl-deprecated.patch

Since the GPL version on the Teltonika is the one released with 01.10 and not 01.11.1, I'm not able to crosscheck, but I assume that the upgrade to libssl.so.1.1 and not applying the patch to LuaSec is the root cause of the problem?

1 Answer

0 votes
by

Hi,

So does the file actually exist on the new firmware? (It does for me and I don't get the same error.) Maybe it was somehow removed, have you tried resetting the router?

by
I did a factory reset on the router, and I still got the same error.

all files exists but when I try to use the Luasec module, the error appears.

using opkg I found out that the latest firmware (00.01.11.1) is using luasec 0.8 but the previous firmwareversion  (00.01.10) is still using luasec 0.6.

The strange this is that the md5sum of the files in both packages are exactly the same, which means that the library isn't updated from a code point of view.

I think, see first post, that the problem is related to the update of libssl (openssl library)