FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
909 views 4 comments
by
After fw update i can't insert ipsec vpn psk with simbols for example % , ( or something like that is someone having the same problem or maybe there is a fix for this?

3 Answers

0 votes
by anonymous
Can you see the logs? If not try to check out the logs

How did you upgraded your firmware? You've should choose without keep all setting. Anyway let me see your logs
by

Problem is here... i can't save psk with ")" if i delete it it allows me to save it

by anonymous
So try to read the docs of this new version maybe these character are not supported
by
But this isn't a solution if i have old vpn configurations that have this character and i can't change  a PSK that is configured so i have problem with this
0 votes
by
So no one have this problem? or just don't using those symbols?
0 votes
by anonymous
Hi,

It's clearly a bug, I will register it. Thank you for pointing it out!
by

The problem persists in FW 00.06.06.1.

If I add the PSK manually in /etc/ipsec.secrets the tunnel works fine. However, /etc/ipsec* files are reproduced at boot time, thus this is not persistent across a reboot. Any suggestion how to implement that in the codebase persistently is appreciated.

edit:

as a workaround add the PSK without special characters in the WebUI -> Save. Then correct the PSK in /etc/config/strongswan. 

Re-initiate IPsec "/etc/init.d/ipsec restart" or reboot.