8317 questions

9780 answers

15562 comments

13905 members

0 votes
765 views 1 comments
by

Im writing a shell script to do config on a RUT240 (FW ver.: RUT2XX_R_00.01.11.1).

I can enable HTTPS acces with :

uci set uhttpd.main._httpsWanAccess='1'
uci commit uhttpd
luci-reload

As far as i can see the HTTPS acces is actually enabled. BUT the WebGUI is not updated not even after a reboot of the router.

Is there other settings i have to set to get the WebGUI to show the actual value?

1 Answer

0 votes
by
Hello,

You have to open an HTTPS port in the firewall.
Best answer
by

Thanks! Your answer led me to find the right solution

What i did in my first post was not necesarry so i set it back to 0 :
uci set uhttpd.main._httpsWanAccess='0'

This is whats needed to enable "General > Access Controll > Enable remote HTTPS access":
uci set firewall.@rule[8].enabled='1'
uci commit
luci-reload

Thanks again for bumping me in the right direction.