4791 questions

5860 answers

9403 comments

5726 members

0 votes
1,024 views 4 comments
by

Hi,

This is the network I implemented to have internet connection on Teltonika which is not working completely:

****

INTERNET

/

/

Main Router (Huawei Fiber optics)

Public IP x.x.x.x

IP LAN: 192.168.1.1

DHCP activated

/

/

Ethernet cable (LAN connection)

/

/

RUT950 Teltonika (RUT9XX_R_00.06.04.5)

WAN wired from Main Router

WAN IP static: 192.168.1.10 (so it is reached by Main Router)

RUT950 LAN Gateway: 192.168.2.1

Then, RUT950 IP LAN range: 192.168.2.xxx, so it assigns that IP range by DHCP to LAN devices connected to RUT950

*****

Then, my laptop connected by WLAN to MAIN ROUTER and by LAN to RUT950 (only during this configuration attempt):

But I can’t navigate on Internet when I force LAN internet connection, even if Windows shows there is internet connection. Furthermore, Anydesk (remote connection software) do NOT stop working and I can ping Google server (8.8.8.8). Really strange.

What could be the problem? This should be related to RUT950 static routers or similar. Main router company provider (ISP) helped me with this configuration, and that main router is not blocking this, so it is a Teltonika problem.

I already created a STATIC route to test, but that did not allow internet connection. Please, see below:

1 Answer

0 votes
by

Hello,

To begin with, delete your "Static Route" on RUT9. It is not needed. By default all "unknown" packets are sent to router's "default gateway". In this case you already specified correct default gateway in "Network -> WAN -> (edit)" menu to "192.168.1.1".

On your computer, instead of "ping 8.8.8.8" try to use "tracert 8.8.8.8" cmd command. This command will show each "hop" between your computer and "8.8.8.8". This will allow you to determine if packets are actually being sent to RUT9, or to Huawei (i.e. through which computer's interface)

Also (at least for testing purposes), try to completely disable your wireless interface on computer so that RUT9 would be the only internet source for your computer. Then try to both "ping 8.8.8.8" from computer and "browse the internet".

by

Hello,

Thanks for so quick answer.

I forgot to comment before that PING from CMD on my laptop did not work. Now I deleted the STATIC route and PING still not working. Every time I test internet connection, I disconnect my laptop from WLAN MAIN router.

TRACEROUTE from Router is working now I deleted the STATIC route but I achieved the same before (I comment this below):

RUT950 with either 192.168.1.10 or 192.168.2.1 is not shown, because TRACEROUTE is executed from RUT950, not from laptop.

As well as deleting the STATIC route I changed Ethernet adapter settings to DHCP (before it was a fixed IP to match RUT950 IP range), and this changed the status to INTERNET connection:

 I achieved this before, and it is the same now: I can ping/traceroute from router, but no internet connection or ping from laptop even if windows shows there is connection:

Please, could this be related to any Firewall configuration? It is strange router reaches internet but not distribute connection to its LAN devices (so far only my laptop). Just a comment- At the very beginning I obtained this same situation by connecting RUT950 to MAIN router by WLAN.

Thank you in advance.

by

Hello,

Thank you for detailed information.

In this case the best approach would probably be to reset your RUT950 to factory default settings and reconfigure it again, since by default everything should be working without any additional configuration (it is possible that your certain configuration changes caused such router's behavior). Or, if your router is not using latest firmware version, upgrade the firmware without keeping any previous settings. Latest RUT9 firmware can be downloaded from here: https://wiki.teltonika.lt/view/RUT9xx_Firmware

After firmware upgrade (or reset to default settings) you do not have to do much, only changes router's LAN IP address and solution should start working (Wired WAN is enabled by default on DHCP mode). On you will have working solution, you will be able to customize it (e.g. change Wired WAN IP to static, etc).

Important: Take note that router's Hotspot's functionality ("Services -> Hotspot" menu) is also working on "192.168.2.0" network. If you will be using Hotspot functionality, either change router's LAN IP to any other network (e.g. 192.168.3.0), or change Hotspot network to any other one.

by
Hi,

I have been able to use internet after restoring Tetlonika to factory settings, then I changed Teltonika Router LAN IP to 192.168.3.1.I did not add any STATIC route on WAN or upgraded the FW. Internet is working both with LAN/WLAN connection to Teltonika.

It is not possible to access Teltonika by its LAN IP 192.168.3.1 either using HTTP or HTTPS, because the new ports for remote connection have been changed, but this should not affect LAN connection. So, to access in LAN I need to use those new ports as well, why?

Problem now is Teltonika remote access is not working even if I changed default configuration and HTTP/HTTPS ports to allow this, but this should be related to Main router, so I will liaise this with the ISP.

Thank you.
by

Hello,

Correct, router's Web interface is working on single port (one port for HTTP and another one for HTTPS). Changing port to another one from "System -> Administration -> Access Control" menu would also mean, that these new ports should be used for local device connection as well.