7608 questions

9041 answers

14582 comments

11888 members

0 votes
1,695 views 2 comments
by

Hello,

after updating RUT955 to latest version (06.05.3) from older 06.04.x, HTTP POST/GET sms_send command does not work anymore as documented here:

https://wiki.teltonika.lt/view/SMS_Gateway#SMS_by_HTTP_POST.2FGET

When trying to send, the response is OK but the message is never received.

For example, this does not work anymore:

http://192.168.1.1/cgi-bin/sms_send?username=aaaaa&password=bbbbb&number=00358xxyyyyyyy&text=Testing_with_00

But, replacing the 00 before country code with "plus" character now works:

http://192.168.1.1/cgi-bin/sms_send?username=aaaaa&password=bbbbb&number=%2B358xxyyyyyyy&text=Testing_with_plus

(%2B is "plus" character encoded in URL)
Will this be fixed in future firmwares to be compatible with older ones?

1 Answer

0 votes
by
Hello,

Just tested RUT955 router with the latest firmware version RUT9XX_R_00.06.05.3 and HTTP POST/GET sms_send command worked just fine.
Router was able to send SMS when using both "00" and plus sign "%2B", when entering phone number.
In my tests I tried with multiple browsers (Chrome, Firewall, Edge) and in all cases I was able to get SMS messages from the router.

If you would go to Services -> SMS Utilities -> SMS Management -> Send SMS window in router's WebUI, you will be able to send  SMS directly from router's WebUI. Please check whether you will be able to receive SMS from router if you would use "00" in phone number, when sending SMS directly from WebUI.
Also please check whether you will not be able to receive SMS using POST/GET string with different browsers.
by

Hi,

now I tested from WebUI SMS utilities like you suggested (fw 00.06.05.3). I receive the message with phone number prefix "+358..." but not with "00358...".

I also tried sending by CLI gsmctl command.

This works:

root@Teltonika-RUT955:~# gsmctl --sms --send "+358xxyyyyyyy test"

OK

This does not:

root@Teltonika-RUT955:~# gsmctl --sms --send "00358xxyyyyyyy test"

OK

(No message is received although there is OK response.)

After downgrading the same device to fw 00.06.04.5, both prefixes work and with both sending methods.

Here's the device information, if it helps tracking down the problem:

Device 

Serial number 1101949712
Product code RUT955T03XXX
Batch number 0050
Hardware revision 1610

Modem

Model EC25
FW version EC25EUGAR06A03M4G
by
Hi,

Via WebUI or SSH try sending SMS with phone number prefix "+358" and then with "00358".

After sending SMS messages, navigate to System → Administration → Troubleshoot  and download troubleshoot file.

Please send this troubleshoot file to me via Private message.