7951 questions

9403 answers

15103 comments

12979 members

+1 vote
3,474 views 6 comments
by
Hello!

Lately, the connection of my RUT240 has slowed down when using 4G connection. It used to be 30+mbit/s, but now it does not exceed 10. If i lock it to 3G only, the speed goes up to around 30. My iphone (same location and provider) gets a high speed connection using 4G.

What can I do to fix this? Rebooting and updating the firmware did not help.

Thanks!
by

Finding same thing, however they have been sub-standard speeds from the start (about 2 months). Also on latest firmware from Feb.

We now have 3 sites using them, and each site we have never seen the download go past 35Mbps with an average being around 18Mbps. Upload would be around 25Mbps and have not seen anything greater.
We have tested using two carriers (Telstra and Optus in AU), and manually selected each LTE band per available below setting and checked speed. 
Also checked the bands that were available including the local tower locations using https://oztowers.com.au/Home/Query – heaps available. Our signal strength is very good being -61 (depending on the band used it fluctuates, however always < -75). We took out the sim’s for both carriers and connected to a Samsung phone - one carrier was getting around the 80Mbps download and other was 140Mbps. Straight back into RUT240 - speeds were <19Mbps. I know the phones have a better CAT rating (CAT6 + as opposed to RUT240 being CAT4) however the RUT240 is advertised as much more.

Anyone able to comment?

Thanks

UPDATE: on reviewing https://wiki.teltonika.lt/view/Mobile_Signal_Strength_Recommendations and based on information stated from other sites about real world speeds for CAT4, the speeds above appear to be normal. Guess need to wait for Teltonika to introduce CAT9 + devices wink

by
Hello,

Thank you for your input.

I still have this problem after the last firmware upgrade. You seem to be getting the same speeds I was getting when mine was working fine. However, lately 4G is only capable of 5-10mbit speeds, while 3G only mode at least delivers 20mbit.

I suppose my device could be faulty.

Regards,

Michael

1 Answer

0 votes
by
Hello,

What kind of signal strength you are having when using LTE? Do yo use both LTE antennas? Also did you tried using latest firmware?

https://wiki.teltonika.lt/view/RUT2xx_Firmware
by
Hi!

I'm getting 4/5 bars of reception. Using both antennas and latest firmware.

It used to be fast, and without changing anything the 4G connection has now slowed down.

Michael
by
Have you tried checking with your Internet service provider ?
by
Yeah. Since the speed is fine on my phone, and used to be good throughvthe router too, and there was no other disturbance in the area, they concluded it was the router.

I have not tried the router in a different location, so I guess that would be a way to test if it's the tower close to me or the router faulting.

And I have not done a factory reset, as I thought even if the problem goes away temporarily it's better to have it replaced if neccessary.

Michael
by
If the cell tower is very close to you could you try removing the AUX antenna ? AUX antenna is the middle one.

Also try adjusting the routers position.