7950 questions

9403 answers

15102 comments

12979 members

0 votes
825 views 0 comments
by

I have the default configuration with lan (192.168.1.0/24) with 4 AP (RUT_333C_2G, RUT_333C_5G, and MAC-Auth), also hotspot (Radius), now I want to a new AP (Whatapp) but with a different subnet lan2 (192.168.254.0/24), I did the configuration, the phone connect to AP and received IP, but don't have Internet connection. below the network and wireless configuratio.

What is wrong?

root@Teltonika-RUTX11:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd72:e921:23c4::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.wan=interface
network.wan.ifname='eth1'
network.wan.proto='dhcp'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].vid='1'
network.@switch_vlan[0].ports='0 2 3'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='0 5'
network.@switch_vlan[1].vid='2'
network.mob1s1a1=interface
network.mob1s1a1.proto='wwan'
network.mob1s1a1.modem='3-1'
network.mob1s1a1.metric='1'
network.mob1s1a1.sim='1'
network.mob1s1a1.pdp='1'
network.mob1s1a1.auth='none'
network.mob1s1a1.method='nat'
network.mob1s1a1.force_apn='-1'
network.mob1s2a1=interface
network.mob1s2a1.proto='wwan'
network.mob1s2a1.modem='3-1'
network.mob1s2a1.metric='1'
network.mob1s2a1.sim='2'
network.mob1s2a1.pdp='1'
network.@switch_vlan[2]=switch_vlan
network.@switch_vlan[2].device='switch0'
network.@switch_vlan[2].vlan='3'
network.@switch_vlan[2].vid='10'
network.@switch_vlan[2].ports='0t 4'
network.lan2_repeater=interface
network.lan2_repeater.lan_mark='lan2'
network.lan2_repeater.proto='relay'
network.lan2_repeater.enabled='1'
network.@route[0]=route
network.@route[0].table='254'
network.lan2=interface
network.lan2.ifname='eth0.10'
network.lan2.proto='static'
network.lan2.metric='0'
network.lan2.ipaddr='192.168.254.1'
network.lan2.netmask='255.255.255.0'
network.lan2.type='bridge'
root@Teltonika-RUTX11:~#

root@Teltonika-RUTX11:~# uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.channel='11'
wireless.radio0.hwmode='11g'
wireless.radio0.path='platform/soc/a000000.wifi'
wireless.radio0.htmode='HT20'
wireless.radio0.country='00'
wireless.radio0.legacy_rates='1'
wireless.radio0.txpower='20'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.network='lan'
wireless.default_radio0.mode='ap'
wireless.default_radio0.ssid='RUT_333C_2G'
wireless.default_radio0.wifi_id='wifi0'
wireless.default_radio0.encryption='psk2+tkip+ccmp'
wireless.default_radio0.key='Mpbn_1010'
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.channel='36'
wireless.radio1.hwmode='11a'
wireless.radio1.path='platform/soc/a800000.wifi'
wireless.radio1.htmode='VHT80'
wireless.radio1.txpower='20'
wireless.radio1.country='00'
wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.ssid='RUT_333D_5G'
wireless.default_radio1.wifi_id='wifi1'
wireless.default_radio1.encryption='psk2+tkip+ccmp'
wireless.default_radio1.key='Mpbn_1010'
wireless.@wifi-iface[2]=wifi-iface
wireless.@wifi-iface[2].encryption='none'
wireless.@wifi-iface[2].device='radio0'
wireless.@wifi-iface[2].mode='ap'
wireless.@wifi-iface[2].wifi_id='wifi2'
wireless.@wifi-iface[2].ssid='Radius'
wireless.@wifi-iface[3]=wifi-iface
wireless.@wifi-iface[3].encryption='none'
wireless.@wifi-iface[3].device='radio0'
wireless.@wifi-iface[3].mode='ap'
wireless.@wifi-iface[3].wifi_id='wifi3'
wireless.@wifi-iface[3].network='lan'
wireless.@wifi-iface[3].ssid='MAC-Auth'
wireless.@wifi-iface[3].macfilter='allow'
wireless.@wifi-iface[3].maclist='10:62:E5:A5:DE:EF' '14:4F:8A:01:06:26' '94:F6:D6:98:C5:9D' '3C:A0:67:57:EB:90'
wireless.@wifi-iface[4]=wifi-iface
wireless.@wifi-iface[4].encryption='none'
wireless.@wifi-iface[4].device='radio0'
wireless.@wifi-iface[4].mode='ap'
wireless.@wifi-iface[4].wifi_id='wifi4'
wireless.@wifi-iface[4].ssid='Whatapp'
wireless.@wifi-iface[4].network='lan2 lan2_repeater'
root@Teltonika-RUTX11:~#

2 Answers

0 votes
by
Did you set up firewall?

You need to allow lan2 forwarding to wan, same as lan>wan.
0 votes
by
Is there some reason vlan2 is configures as 'untagged' on WAN port by default, on factory settings? Does router use vlan2 by itself for some purpose?

I wasn't sure about that and chose vlan 3 for first user defined vlan. Before that I tried to remove vlan 2 from WAN port but i gave problems, slow speeds on wan or something.