10459 questions

12458 answers

19381 comments

21888 members

0 votes
1,397 views 11 comments
by
Hi

I have a RUT 950 running the latest RUT9XX_R_00.06.05.3. (which it installed automatically recently)

The router is connecting to the internet via 4G.

It works fine but then after a period, normally a day, it stops communicating with the Internet, so devices report no internet connectivity.

It remains connected to the 4G system, the web admin still works and everything looks good but no traffic is going out over the connection.

A software reboot via the web admin does not resolve the problem. It boots up, connects to the 4G network but the connection shows no traffic.

A power off/on DOES resolve it and it works fine again for a time before the problem reappears.

I have a friend who has the same router, same 4G SIM supplier and same Firmware is having exactly the same problem.

I am thinking that the recent firmware update may be the problem as it has been working fine for years. A while ago I manually updated the firmware and set it to do automatic updates (FOTA) so now it is always using the latest firmware.

I would appreciate any ideas on what the problem is or why the latest firmware would cause this.

Thanks!
by
How are you powering the RUT? The supplied AC to DC power supply or are you powering it from a DC source, ie Battery?
by
Also, out of curiosity, have you tried a disconnect and reconnect through the GUI on the 4G service?
by
Hi Justin

Thanks for taking the time to reply :)

In answer to your questions:

I'm supplying it from AC with the supplied transformer.

It just locked up again, I went into the GUI and searched for operators and picked the correct one and it re-connected....

The plot thickens!

Thanks

Matt
by
Was it previously set to 'Auto' on the network selection?

Have you selected to correct APN?
by
What signal are you receiving?
by
Hi

Same data connection problem i have with RUT950 about two or three times per month. Problem begann with the first 4G router in use. The former RUT500 3G Router works propely since two years without any interrupt of data connecion in the same application.

State check of router connection via SMS displays correct data connection.
 "WAN IP 172.XX.XX.XXX ; Data Connection state - connected, Connection type - LTE; signal Stregth - -71dBm, New FW availabel - No"
But neither PING check nor Portscan via my IP provider are successful.

Workaround:
-To solve the problem i send "reboot" via SMS and after about 20 minutes the router works properly again.
-I programmed "periodic reboot" one time a week.
I will increase the intervall to one time a day if problem won't be solved via new firmware update in the future.
-I assumed the problem in net selection switching between 3G and 4G. So I changed router setting to 4G-2G only, with the result los of data connection because of bad 4G net more often than before. I changed setting to "Auto" again.

I try to keep the router firmware up to date, but problem keeps still present after several updates i did in the last year.

I hope my post helps to solve the problem.

Thanks

Stefan
by
Hi,

I’m actually experiencing something somewhat similar. My RUT955 is mounted in one of or work vehicles and currently experiencing the RUT sticking to 3G (WCDMA) when the 4G signal is better. It’s connected to 3G at -69dBm, I actually thought it was offline due to horrible slow internet (3G related).

I’m considering subscribing to RMS just to check the state of the unit.

I guess I could force mobile service to 4G but that limits the unit when signal is genuinely low.

Soft Reboot didn’t make the RUT switch to 4G either.

I’ll do some testing and config changes and keep you all posted.

1 Answer

0 votes
by

Check whats happening in the status logs

Status -> Events Log -> Network Events -> Mobile Data also Check -> Network Operator

See if the service is actually disconnecting or if there is a problem somewhere else.

After checking logs, you could try plug in a hardwired WAN cable from your home router or similar and see if thats dropping out also.

Best answer
by
Hi

So logs show the data is connecting, then disconnecting after a certain period and it's doing this repeatedly.

I know it's not the 4G network as my phone is connected to it (same company SIM) as well as a small portable 4G router (again same 4G SIM supplier) that I'm using to write this!

So I'm no closer other than for some reason, this router seems to be not able to hold a connection. As I said I have a friend neaby with the same router and SIM supplier and he is seeing the same behaviour.
by
So yesterday I took the firmware back to the previous version 06.04.5 to see if it was the latest version that was causing it. It wasn't, problem still there.

When it's working it's fine (I'm using it now). This morning, with no usage overnight it had disconnected. I rebooted the router and it connected. An hour or so later it did it again.

Please can you remove the answer as this is not yet solved.
by
Just a thought, there is a ‘keep alive’ setting under mobile data settings. Have you got this enabled? I think this could be troublesome if enabled.
by
Thanks all for the advice and experiences.

We still have the problem. Thought I'd found it for a moment there, the system clock was out and when I set it, it seemed to work better. However a while later it stopped again.

It's really strange and as I said I have a friend with the same router with the same problem so it's not a one off.

I don't know what else to try though, tried all the suggestions above. It seems to stay connected but no packets are going in or out on the 4G interface. It's almost like the routing table gets messed up, although it looks to be fine, default gateway etc etc.

I don't know where to proceed from here (other than to buy something else!)

Thanks again.