8400 questions

9885 answers

15679 comments

14155 members

0 votes
854 views 2 comments
by
Extremely slow speeds on Tmobile LTE in US. I am getting 1-2Mbps on the RUT240 where Im getting 50Mbps on my cell phone on tmobile. Anybody have a solution or os the RUT240 just that bad?

1 Answer

0 votes
by
Hello,

Please check if:

- router is using latest FW: https://wiki.teltonika.lt/view/RUT240_Firmware_Downloads

- both LTE antennas are attached to the router

- no QoS is configured on device: https://wiki.teltonika.lt/view/QoS

- no additional device are connected who can reduce LTE speed

Also, please comapare RUT240 LTE speed to similar device/router who is using CAT 4 LTE module in the same place with the same SIM card.
by
I am also getting very slow speeds (2.5 Mbps download and 1.8 upload). My phone in the same location is much faster (14.8 download and 10.3 upload) and is very variable. It changes hugely every time I do a speed test. I have updated with the latest firmware (12.2) and have no QoS settings. This surely can't be right. Please help. There was no point in buying this device if I'm getting such low speeds
by
Hello,

Thank you for your information.

I would like to mention, that router and smartphones have very different hardware, and usually smartphones has better mobile connection speeds then router in some cases.

I recommend try testing with similar device (router) which supports CAT 4 LTE module and see if another router would perform same or even better when using same SIM card as in RUT240 and also in the same location and see what results will you get.

Also LTE speed depends on environment, to what cell tower it is connected, what band it is using, how heavily the cell tower is loaded by other users, what signal strength you are getting with RUT240 and etc.