8848 questions

10502 answers

16464 comments

15792 members

0 votes
779 views 0 comments
by

Hello!
When I try to install SQM (Smart Queue Management) openwrt package with the command "opkg update && opkg install luci-app-sqm" I get this error:

Installing luci-app-sqm (1.2.4-1) to root...
Downloading http://downloads.openwrt.org/releases/18.06.4/packages/arm_cortex-a7_neon-vfpv4/packages/luci-app-sqm_1.2.4-1_all.ipk
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-sqm:
*      kernel (= 4.14.131-1-010b32e6fa40a9fbb80e18acebab96c4)
* opkg_install_cmd: Cannot install package luci-app-sqm.

How to solve this problem? My router is rutx09 (firmware: RUTX_R_00.02.01.1).

1 Answer

0 votes
by
Hello,

At this moment, there really isn't anything you can do without changing router OS to something that would fit kernel dependency. You can also try using opkg force options, but that is generally bad idea, for one it does not mean that even if it installs it will work fully or even at all, and if you force rewrite config files, it might mess up some other functions or even router OS.

Regards,
VidasKac