8298 questions

9759 answers

15542 comments

13863 members

0 votes
6,936 views 11 comments
by
Hello.

We've recently purchased RUT955 units for AT&T and Verizon networks in the US.  Both are connected to the networks properly.  Our specialized service has public static IP addresses on each carrier and does not block any ports or functionality.  We use this service with many brands of LTE routers with no problem.

The RUT955 will not port forward from the LTE modem to any LAN side devices.  We've reconfirmed multiple times that the setup is correct.  The LTE modem is set as the primary and only active WAN connection.  We have confirmed through CLI that the Linux routing tables are correct.  We can access the unit configuration through the web management port from the LTE modem, just no additional ports on the LAN side.

Is my team missing something?  Is this a bug?  Or by design?  We've tried multiple different versions of firmware with the same result.

My company would like to deploy a large amount of these units to our customers, but without port forwarding working, it's a non starter.

Thank you!
by
Hello,

we seem to have the same issue with port forwarding on RUT240. Using a mobile connection, the SIM is configured with a static public IP. Port forwarding does not work. Surely could be a configuration issue, but enabling remote SSH connection on the router itself using GUI does not work either (port is closed)...

Was this solved by any chance?

Thanks

3 Answers

0 votes
by

Hi, Its certainly not a bug or issue with the firmware if you're running the latest 'FW ver.: RUT9XX_R_00.06.05.3'

Are you doing the port forwards via CLI or GUI?

My recommendation would be to;

- Default the RUT back to factory defaults, setup the WAN again. 

- Make sure that you're using the correct APN for your service provider to obtain a Public ip address

Then setup the port forward in the GUI Network --> Firewall, Port Forwarding.

Make sure that 'enabled' on the forward rule is ticked. Hit Save and wait for it to write the config.

- Click 'Edit' on the port froward line you just did, then scroll down to the bottom and check 'Enabled NAT Loopback' (just incase you're testing the port forward from the same WAN)

Let me know how you get on smiley

by

If the above still fails, i'd recommend trying to forward a different external port to the same internal port, ie External 8000 to Internal 80, just to be 100% sure that your carrier isn't blocking the port that you're trying.

by
Forwards were all done via GUI.  CLI was only to confirm that routing tables were correct.

All of the steps you outlined were exactly what we did multiple times with the same result.

As I said in my original post, I know the carrier isn't blocking ports.  I operate an MVNO so I'm very well versed on how my APNs are configured.  We configure and ship at least 5 LTE systems a week.  I've never had this problem.  We've confirmed functionality on the same SIMs in Cradlepoint and Pepwave devices and port forwarding works fine.

That's what's so maddening about this.  I know we've followed what should be the correct steps.  But nothing is forwarding on either carrier/router.
by

Try doing a port forward as below and see if it works.

Forward any external source port 8000 to internal port 80 on 127.0.0.1, enable NAT loopback

Run https://www.yougetsignal.com/tools/open-ports/ from within the same WAN and enter port 8000. What are your results?

Also under Network WAN, make sure that the radio button 'main' is checked on the 'Mobile WAN'

by
Guessing this fixed the issue?
0 votes
by
Hello,

Have you set router's LAN IP as default gateway in your LAN devices network configuration?
If one of your LAN device have Web interface, have you checked whether it could be reached locally via router from PC?
As in your case port forwarding rule does not work when using LTE connection, have you tried setting Wired WAN and checking whether port forwarding rules work correctly?

If none of the above method works, please send me router's troubleshoot file once the issue is present.
Troubleshoot could be downloaded via router's WebUI (System→  Administration → Troubleshoot).
Also in System →  Administration → Troubleshoot window, enable TCP dump and save router's configuration.
Once TCP dump and your port forwarding rule are enabled, try reaching LAN device via your created port forwarding rules.
After that download TCP dump file and disable TPP dump on the router.
Please provide downloaded TCP dump file with troubleshoot file via private message.
by

Greetings from Finland.

I work for a large telco in the nordics in the IT-infrastructure team, and i am not exactly clueless either.

My port forwarding does not work either - i carefully read, traced and verified all steps above
and "https://www.yougetsignal.com/tools/open-ports/" as well as serfish.com  confirm the ports are "closed"

However, i make mistakes.. i miisunderstand instructions, so here i am hoping it was me doing something wrong
i like the router otherwise, but if it cant port forward then it i will be looking elsewhere.

What adds insult to injury is that there is no proper firewall logging, so i cannot even check if a firewall rule is the cause.

------------- port forwarding rule:


best regards
timo



 

by
Hi.

Can you solve the forward port problem? I have the same problem but with OpenVPN connection...

Thank you in advance!
by
Hi,

Port forward is working just fine on the routers.
If you will send private message with router's troubleshoot file and your network topology with IP addresses, I could check what might be causing the issue in your solution.
by
Hi, any news on this? Because I'm also facing the same problem: RUT950 firmware...quite all...from 00.06.05 on...

Very simple situation: the router (192.168.1.1) a pc (192.168.1.130) and a cam (192.168.1.100); the cam has a web server.

Both from lan or wan I cannot forward any port (I try 8080,8081,8082, etc.) to 192.168.1.100:80 web server. An example:

From 192.168.1.130 I can browse both 192.168.1.1:80 and 192.168.1.100:80

From 192.168.1.130 I CANNOT browse 192.168.1.1:XXX

Any help would be appreciated
0 votes
by
Hi,

I have just been in contact with the tech team at Telenor, a swedish telco. I called them when I realized that my RUT950 did port forwarding intermittently depending on which IP range it got the WAN IP from. I found out that when my router got IP from 79.x.x.x or 178.x.x.x I could reach the service behind The router but when I got an IP from the range 100.x.x.x It did not work. I was sure they had blocked that range and maybe put that IP range behind a firewall. But they have not. After long discussions we were sure that the problem is in the code of the router RUT950. Please Teltonika, look into this asap.
by
Spent some hours on this over the weekend, i can not get it to work either. Using Telenor with apn set to Internet.public. Getting a public ip in 79.x.x.x range, nothing reaches my forwarded device on the lan. Rules are enabled, forwarding 9191 to 9191 on specific lan host. From inside the lan the webserver on 9191 is up and responding. Close to returning device as this worked with no issue on old dlink router, hoping I have just missed some annoying detail somewhere
by
I use the APN services.telenor.se. With that APN the IP ranges 79.x.x.x and 178.x.x.x works. 100.x.x.x do not. I will get a fixed IP from telenor in the 79 range in a week or two. Until then I send Reboot via SMS to it and hope it gets a "working" IP address :).