7662 questions

9091 answers

14654 comments

12056 members

+1 vote
649 views 2 comments
by
In the download page, there is no Linux driver.

Whre can I find it?
I need to use the modem with a Raspbian Jessie and the kernel is the 4.4.50-rt66 version.
by
I changed the distribution to a Raspbian strecth kernel 4.9.76-rt60 and it works well

1 Answer

+2 votes
by

Hello,

Great to hear.

However, using Raspian Jessie distribution you do not need additional drivers, just additional packages: modemmanager and network-manager, required to configure modem and get IP address.

  • First you have to enter command mmcli -L to get list of connected modems and indexes, if only one modem connect then index is most likely 0. If error appears that no modems were found, restart RPI system and do this command again.
  • Then with command mmcli -m <INDEX> you can check information about modem.
  • If your SIM card has enabled PIN, then with command mmcli -i <INDEX> --pin=<PIN_CODE> you will unlock you card
    • Additional commands for PIN management:
      • mcli -i 0 --pin=<PIN> --enable-pin
      • mcli -i 0 --pin=<PIN> --disable-pin
      • mcli -i 0 --pin=<PIN> --change-pin=<NEW_PIN>
      • mcli -i 0 --pin=<PIN> --puk=<PUK>

After this you can add cellular connection

  • First you have to configure interface to know how to connect to modem and what parameters to use. For this use command nmcli c add type gsm ifname <interface> con-name <name> apn <operator_apn>
    • here <interface> - is string listed as "primary point" in mmcli -m <INDEX> command return;
    • <name> - is an arbitrary name to identify the connect, you can use any string;
    • <apn> - your SIM card APN.
  • nmcli r wwan on - might not require
  • To disable connection use command: nmcli r wwan off
  • By default system is configured to autoconnect, if you want to change this use command:
    • nmcli c modify <name> connection.autoconnect [yes|no]
    • nmcli c down <name> - will turn connection off

If you have to enter more parameters (APN, username, pasword and etc) to establish connection with operator or just ensure that PIN is always entered use this command:

  • nmcli c add type gsm ifname <interface> con-name <name> apn <operator_apn> username <user> password <password> pin <PIN>
Best answer
by

Curiously the command mmcli -m 0 returns the following as part of its output:

Status   |           lock: 'unknown'
         | unlock retries: 'unknown'
         |          state: 'failed'
         |  failed reason: 'sim-missing'
         |    power state: 'unknown'
         |    access tech: 'unknown'
         | signal quality: '0' (cached)

It is definitely not the case that the SIM is missing, I can even confirm that under Windows 10 the system is working and the device can reach the Internet.

After the configuration suggested above (command nmcli c add type gsm ifname <interface> con-name <name> apn <operator_apn>), I cannot see any error; still, I can't access the web.
Any guess on how I could troubleshoot this problem? Thanks in advance.

System info:
pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux
pi@raspberrypi:~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 9.13 (stretch)
Release:        9.13
Codename:       stretch

[UPDATE]: When I try to take up my new connection, the system returns:
Error: Connection activation failed: No suitable device found for this connection.