10921 questions

13023 answers

20289 comments

27183 members

+1 vote
584 views 2 comments
by

Hello, we're using the RUT955 as ntp server. The problem is that it happens that when we reboot the system, the date that we get from gps is wrong. The router is installed on a LAN without Internet access.

We're using the test firmware "RUT9XX_T_F1835_00.06.05.20_WEBUI.bin" as previously suggested in other post, to fix gps time issue.

When we reboot the system, the gps time seems correct, while the gps date is wrong:

root@Teltonika-RUT955:~# gpsctl -tpse

963397207

3

1

2000-07-12 12:20:07

After some time has passed after the reboot, it can happen that the date turns out to be correct too, in a random way.

But we need the correct date and time since the first time the device boots, otherwise it can pass a wrong information to other devices that sync date/time on our ntp server.

Could you have a look at this issue?

Thank you.

2 Answers

0 votes
by
Hello,

Could you attach troubleshoot of the mentioned device.
by

Hello, today I have not been able to reproduce this issue. After every reboot of the system, the gps gives correct both date and time.

I also restored the system to the factory firmware (RUT9XX_R_00.06.05.1), to check if it the bug could be related to the update of the firmware (that I did Yesterday, when I installed the test firmware), but still the problem didn't occurr.

In any case I got the troubleshoot file so you can have a look at it:

https://drive.google.com/file/d/1LVDWeUUbgOfCIO684jOG2nlNL4Gtp_8d/view?usp=sharing

I will try again tomorrow to see if I can reproduce it again.

Of course we're interested that this kind of problem doesn't happen again, and now to know the reason why yesterday was happening and now it's working properly. 

Thank you for your support, regards.

by

I just reproduced the problem. I rebooted the device and this is the result of the command:

root@Teltonika-RUT955:~# gpsctl -pste
5
1
963506297
2000-07-13 18:38:17

Because I have written a script that sync the system date/time to the gps date/time, the system date/time is affected by this. And the ntpserver will give wrong information.

I attach the relative troubleshoot file:

https://drive.google.com/file/d/1DUAPWkcg3_DPwtDRONfDOyu00VCHkBNE/view?usp=sharing

Thank you for your support, regards.

0 votes
by
Hello Sir,

Thank you for your feedback and information. It helps us a lot. New fixes have been installed in a new version which is still being tested. Subscribe to the Teltonika newsletters and you will be informed when firmware will be available.

Best regards