4451 questions

5470 answers

8586 comments

5378 members

0 votes
283 views 0 comments
by

I am trying to connect to openvpn cloud. But i cannot get the router to connect. I have tried with the opvn file, witch does not work, and manually setting it up.

I might be missing something that have to be set up in extra settings. Do anyone know what this could be.

I have an example of the opvn file:

setenv USERNAME "XXXXXX/connector/xxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx_xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxx"

# OVPN_WEBAUTH_FRIENDLY_USERNAME = "XXXX/XXXX/Test"

client

dev tun

remote eu-central.gw.openvpn.cloud 1194 udp

remote eu-central.gw.openvpn.cloud 1194 udp

remote eu-central.gw.openvpn.cloud 443 tcp

remote eu-central.gw.openvpn.cloud 1194 udp

remote eu-central.gw.openvpn.cloud 1194 udp

remote eu-central.gw.openvpn.cloud 1194 udp

remote eu-central.gw.openvpn.cloud 1194 udp

remote eu-central.gw.openvpn.cloud 1194 udp

remote-cert-tls server

cipher AES-256-CBC

auth SHA256

nobind

verb 3

socket-flags TCP_NODELAY

<ca>

-----BEGIN CERTIFICATE-----

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

-----END CERTIFICATE-----

</ca>

<cert>

-----BEGIN CERTIFICATE-----

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

-----END CERTIFICATE-----

</cert>

<key>

-----BEGIN RSA PRIVATE KEY-----

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

-----END RSA PRIVATE KEY-----

</key>

key-direction 1

<tls-auth>

-----BEGIN OpenVPN Static key V1-----

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

-----END OpenVPN Static key V1-----

</tls-auth>

## -----BEGIN RSA SIGNATURE-----

## DIGEST:SHA256withRSA

## xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

## xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxI

## -----END RSA SIGNATURE-----

## -----BEGIN CERTIFICATE-----

## xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

## xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxw

## 

## -----END CERTIFICATE-----

## -----BEGIN CERTIFICATE-----

## xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

## xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

## -----END CERTIFICATE-----

2 Answers

0 votes
by

Hello,

Is there a particular reason why remote eu-central.gw.openvpn.cloud 1194 udp repeats 7 times in your configuration? It seems a bit odd.

Could you also attach logs from the server while router is trying to connect? It may help build a better view of why router might not connect.

Also, was there any guide you were following? Maybe you could link it in this thread?

Best answer
0 votes
ago by

It's gone 7 months since you asked your question. I stumbled across it as I had the same problem for my RUT950. So if you're still interested or maybe someone else, here is how I got it to work. Just importing the ovpn cloud profile didn't work so I had to do it manually.

1) First update the router firmware to the latest version. In my case i'm now running

RUT9XX_R_00.06.07 2020.09.30

2) Extract the certificates from the ovpn profile (-----BEGIN CERTIFICATE----- to -----END CERTIFICATE-----) for ca, cert, key and static key (ie <tls-auth>) into four separate files.

3) In the VPN client manual setup enter the following. (settings not below are left blank)  
Enable = True
TUN/TAP = TUN (tunnel)

Protocol = UDP
Port = 1194 (or your own portnr)
LZO = True
Remote host/ IP address = xxx.xxx.openvpn.cloud (copy your adress from profile line 6, remote)
Resolve retry = infinite
Keep alive = 10 120
Authentication = TLS/Password
Encryption = AES-256-CBC 256
TLS Cipher = All
HMAC authentication algorithm = SHA256
Additional HMAC authentication = Authentication only (tls-auth)
HMAC authentication key = Upload your static key file from step 2
HMAC key direction = 1
User name = your full openvpn cloud username from the first line in the profile (setenv USERNAME)
Password = your password 
Certificate authority = upload your ca file from step 2
Client certificate = upload your cert file from step 2
Client key = upload your key from step 2


Also important.
Your router must support IPV6. (Enable under System / Administration)

Hope this helps anyone trying to connect to openvpn Cloud.