FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+3 votes
2,552 views 5 comments
by
I am trying to read data from serial rs232 using console mode on rut955. I have configured the serial mode, however I don't get any data, While I can get data from the same serial source on my laptop.
by
Ilias was using Cat /dev/ttyS0 command

Also, no interfaces had been enabled. Should this make a difference?
by

We're also trying it over TCP/IP, but still not able to get any data. Here's a screenshot: https://www.dropbox.com/s/dly1397gxjtxm5g/teltonika.png?dl=0

by
Thanks for the reply. Actually, what we want is something else.

We have a solar controller which has RS232 output. When I connect that to a PC I can read it. I want to read it via the Teltonika, ultimately using RS232 Server over TCP/IP mode, but provisionally any mode, including console.

What I've tried is: Connecting the Solar Controller via RS232 to the Teltonika, enabling Server > Console mode and using cat /dev/ttyS0 on the CLI which works from a PC, but doesn't work on the Teltonika.

We've also experimented with TCP/IP mode, still no success.

1 Answer

0 votes
by anonymous
Hello,

With console mode you can connect your PC to the router via RS232 and you will be able to get into routers console.

You just need to select correct COM port and baud rate: 115200
by anonymous

Thanks for the reply. Actually, what we want is something else.

We have a solar controller which has RS232 output. When I connect that to a PC I can read it. I want to read it via the Teltonika, ultimately using RS232 Server over TCP/IP mode, but provisionally any mode, including console.

What I've tried is: Connecting the Solar Controller via RS232 to the Teltonika, enabling Server > Console mode and using cat /dev/ttyS0 on the CLI which works from a PC, but doesn't work on the Teltonika.

We've also experimented with TCP/IP mode, still no success.

by anonymous