10072 questions

12024 answers

18641 comments

20094 members

0 votes
1,134 views 6 comments
by
Hello. We do have an Issue Regarding to T Mobile SIM Problems. The RUTX11 works great with the D2 Vodafone SIM.

If we are using a T Mobile SIM, the SIM connects successfully, is registered, Data Conection is connected to 4G at e.g. -69dB.

But there ist no online connection possible. In the WebUi  - Network Menu - Mobile we can see the actual SIM state. In the last two rows there is the possible Issue: Bytes send is increasing very slowly, Bytes received stayes at 0kB.

We are able to recreate this issue in our factory with another pair of T Mobile SIM cards an a second RUTX11 Router

Maybe there is just a little configure Issue, but we do not have many experience with Teltonika Routers yet.

The Model is the RUTX11, newest Firmware available installed on both Devices.

2 Answers

0 votes
by

Hello,

What does it say in Network > Mobile next to SIM state? Connected?

Also what APN are you using? custom or Auto?

Best regards,
VidasKac.

by
Hi. The SIM state is "only" inserted. not connected. The Data connection does show connected.

But the hint with the APN obviously gave the proper solution.

I've only tried Automatic APN. After switching Auto APN off, and selected the internet.telekom Provider (after scaning available operators at Network - Mobile - Network operators )

the Connection is fine. I will call our Customer to try this solution, and i really think the problem is solved.

Note: The SIM state is "inserted" yet as well.

Many thanks and kind regards from Germany.
by
Hello,

Glad to hear that, hope this was the issue, but if something will not work for yours customer let me know here, I'll do my best to help.

Best regards,
VidasKac.
by
Same here: I have a RUT240. Everything looks good, but no Bytes travel through the air.

Then I changed APN to custom and entered "internet.telekom" in the custom-apn-field. Now everything works.

So, maybe there is a flaw in the APN-Database in the firmware?
by
Hello,

Well basically, we do not have each APN of every Mobile service provider in every region, it is a work in progress and we try to increase the number with each FW upgrade that we do. But their number is ever increasing and some even change, so even if we would manage to get them all at one point, week later database can be lacking few APNs.

Hope you understand that, and that it was not too big of an inconvenience.

Best regards,
VidasKac
by
Great. Had the same issue and found this thread. That helps. The interesting thing is, just choosing the "internet.telekom" entry in the drop-down list wouldn't work, but selecting "Custom" and entering "internet.telekom" as the APN worked instantly.

I would bet a month ago with an older Telekom SIM everything worked out-of-the-box (only tested it then, but remember I was amazed by plug-and-play).

A little strange, tried everything including factory reset, firmware flash etc. But the solution really is the custom APN.

Thanks
0 votes
by
I must confirm the solution for the APN-issue with Telekom in Germany.
I had to choose custom apn and enter internet.telekom to be able to make data connections.

With auto-Apn or just the right list selection the RUT955 was registered and had an IP (private), but no data conn was possible.
Thx for this threat!!! I was already testing different RUT955s and different SIMs.
And yes - that is a change to older sims - so either Telekom or Teltonika has done "something" - with RUT240 working (see above) my finger tipps to Teltonika ;-)

Regards - nice hardware anyway.
by

We have the same problem. It is a problem for us because we cannot deliver the RUT240 pre-configured to our customers because we cannot know what SIM cards they use. So if our customer chooses Telekom as their ISP, the router won't come online because manual intervention is necessary.

Well basically, we do not have each APN of every Mobile service provider in every region, it is a work in progress and we try to increase the number with each FW upgrade that we do. But their number is ever increasing and some even change, so even if we would manage to get them all at one point, week later database can be lacking few APNs.

Hope you understand that, and that it was not too big of an inconvenience.
 

This doesn't make sense to me. I have the same issue with Telekom Germany, when I disable auto APN and chose the only one from the list it works. How did the RUT240 know the APN name? There's only two possibilities if I'm not mistaken: Either it was already in an internal list inside your firmware, or the RUT240 was somehow otherwise able to determine the APN name.

Also, this below indicates that there is actually a bug in the firmware, why would it work when typing it in but not when selecting it from the list?

Great. Had the same issue and found this thread. That helps. The interesting thing is, just choosing the "internet.telekom" entry in the drop-down list wouldn't work, but selecting "Custom" and entering "internet.telekom" as the APN worked instantly.