10908 questions

12999 answers

20267 comments

26733 members

0 votes
1,207 views 12 comments
by
i would like to use the Rut950 as a BGP router, the config itself isn't that difficult but the peer requires MD5 authentication, i don't see an option to set a password in the WUI but i also can't find the correct way to put the config together in the CLI.

does anyone has any solution for this ??

2 Answers

0 votes
by
Hello,

Regarding to this problem of yours could you provide us some information what device are you going to connect to RUT950 via BGP?
Also can  you share the config that is requested by the peer? We need this information so that we can assist you furthermore.

I have here a short manual regarding BGP configuration with our device i hope it helps a bit : https://we.tl/t-YYgE1GsRiY

Thank you and have a nice day!
Stay Safe

Regards,
Jerome
by

Hello good day hope your safe and doing well. 
Could you try doing adding example command "neighbor 10.0.0.2 password 123456pass" on the config file of bgp that can be done by connecting to SSH then do the "vi" command.

Command: vi /etc/config/quagga/bgpd.conf 
It will give you this slight similar result like the image shown below: 
 

navigate to the router bgp settings on the network part press "a" button on your keyboard to start editing. 
Then from that you can input neighbor 172.29.254.254 password testing now to save your edited config press "esc" 
then type  ":wq" then input command "/etc/init.d/quagga restart

If you have problem executing this command feel free to ask help we can do a short remote session for this.

Thank you and have a nice day!
Hope it helps,

Stay Safe

Kind Regards,
Jerome

by

Jerome,

i allready have been busy with manual editing on CLI but did it again conform your post.

vi /etc/config/quagga/bgpd.conf seems to be creating a new file

~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
- /etc/config/quagga/bgpd.conf 1/1 100%

FYI: bgpd.conf seems not to be located in that directory

root@Teltonika-RUT950:~# ls /etc/config/quagga/bgpd.conf
ls: /etc/config/quagga/bgpd.conf: Not a directory
root@Teltonika-RUT950:~# ls /etc/config/quagga/
ls: /etc/config/quagga/: Not a directory
root@Teltonika-RUT950:~# ls /etc/config/quagga
/etc/config/quagga
root@Teltonika-RUT950:~# find / -name bgpd.conf                                                    
/etc/quagga/bgpd.conf
/overlay/upper/etc/quagga/bgpd.conf
/rom/etc/quagga/bgpd.conf

if i add the change to /etc/quagga/bgpd.conf or /overlay/upper/etc/quagga/bgpd.conf the change will dissapear after restarting quagga

/rom/etc/quagga/bgpd.conf doesn't show any BGP info

dont know if it makes any diffrence but i have     FW ver.: RUT9XX_R_00.06.06.1

 

by
Jerome,

i also tried to make changes with uci

root@Teltonika-RUT950:~# uci show quagga
quagga.ospf=ospf
quagga.ospf.enabled='0'
quagga.ospf.debug='0'
quagga.ospf.enabled_vty='0'
quagga.rip=rip
quagga.rip.enabled='0'
quagga.rip.debug='0'
quagga.rip.enabled_vty='0'
quagga.general=general
quagga.general.debug='0'
quagga.general.enabled='1'
quagga.general.enabled_vty='1'
quagga.default=instance
quagga.default.as='64991'
quagga.default.id='172.29.250.1'
quagga.default.enabled='1'
quagga.default.network='192.168.1.0/24'
quagga.default.redistribute='connected'
quagga.default.deterministic_med='1'
quagga.nhrp=nhrp_global
quagga.nhrp.enabled='0'
quagga.nhrp.debug='0'
quagga.@peer[0]=peer
quagga.@peer[0].instance='default'
quagga.@peer[0].as='28685'
quagga.@peer[0].ipaddr='172.29.250.2'
quagga.@peer[0].enabled='1'
quagga.@peer[0].default_originate='1'
root@Teltonika-RUT950:~#
root@Teltonika-RUT950:~# uci set quagga.@peer[0].password="123456Pass"
root@Teltonika-RUT950:~#  uci show  quagga.@peer[0].password=
quagga.cfg063511.password='123456Pass'
root@Teltonika-RUT950:~# vi /etc/quagga/bgpd.conf            # doesn't show changes
root@Teltonika-RUT950:~# vi /overlay/upper/etc/quagga/bgpd.conf        # doesn't show changes
root@Teltonika-RUT950:~# /etc/init.d/quagga restart
quagga.init: Stopping watchquagga ... killed 3179 ... done.
quagga.init: Stopping bgpd ... killed 3175 ... done.
quagga.init: Stopping zebra ... killed 3171 ... done.
quagga.init: Starting zebra ... done.
quagga.init: Starting bgpd ... done.
quagga.init: Starting watchquagga ... done.
root@Teltonika-RUT950:~# vi /etc/quagga/bgpd.conf            # doesn't show changes
root@Teltonika-RUT950:~# vi /overlay/upper/etc/quagga/bgpd.conf        # doesn't show changes
root@Teltonika-RUT950:~#  uci show  quagga.@peer[0].password
quagga.cfg063511.password='123456Pass'
root@Teltonika-RUT950:~#
by
Hello,

Could we do a short remote session for this issue of yours? :)

Kindly communicate with me via pm.

Thank you and have a nice day!
Stay Safe.

Kind Regards,
Jerome
by
Hello,

Regarding this query of yours it is still pending on our RnD Team once i have the information about solving your problem.
I will be sharing it to you directly.

Thank you for your patience and understanding.
Have a nice day!

Stay Safe.

Regards,
Jerome
0 votes
by
Hi,

Unfortunately, ours router do not have such option. This requires additional development, for this, contact with your sales manager from Teltonika