FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,765 views 2 comments
by
Hi,

I configured two RUT230 routers with cli access but, for security reason, I didn't activate remote administration via web. Now my client needs it. Is there any way to activate using uci commands or editing a configuration file

1 Answer

0 votes
by anonymous

Hi,

To enable HTTP/HTTPS access via CLI modify config file located in /etc/config/uhttpd using vi text editor.

In this file you'll find lines:

        option enablehttp '0'

        option enablehttps '0'

Set these fields to 1 and save the changes to configuration.
by

Thanks for your answer but I have enabled http and the router is not accessible from remote. Maybe this is not enough for remote administration.

My configuration is:

config uhttpd main                             

        list listen_http        80             

        list listen_https       443            

        option enablehttp       1              

        option home             /www           

        option rfc1918_filter   1              

        option max_requests     3              

        option max_connections  100            

        option cert             /etc/uhttpd.crt

        option key              /etc/uhttpd.key

        option cgi_prefix       /cgi-bin       

        option script_timeout   600            

        option network_timeout  30             

        option http_keepalive   20             

        option tcp_keepalive    1              

        option ubus_prefix '/ubus'             

                                               

config uhttpd hotspot                          

        list listen_http        81             

        list listen_https       444            

        option enablehttp       1              

        option home             /www/hotspot   

        option rfc1918_filter   1              

        option max_requests     3              

        option max_connections  100            

        option cert             /etc/uhttpd.crt

        option key              /etc/uhttpd.key

        option cgi_prefix       /cgi     

        option script_timeout   600      

        option network_timeout  30       

        option http_keepalive   20       

        option tcp_keepalive    1        

        option no_dirlists '1'           

        option ubus_prefix '/ubus'       

        option disabled '1'     

Thanks a lot

by anonymous

Hi,

Then you need to insert line:

        option _httpWanAccess '1'

Into "config uhttpd main" section of configuration