FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
823 views 5 comments
by anonymous
After downloading firmware for the TRB142:  TRB14X_R_GPL_00.02.03.1.tar.gz and running make on Ubuntu 1804, compilation fails for the common module: aboot.

Apparently, there's an (old) .config file included, which selects a number of TRB modules, but also selects aboot for which apparently not the correct preconditions / libries / headers are included by default ?

Anyone got success in building the firmware for the TRB142 ? What did you change / menu-configured  or installed separately?

1 Answer

0 votes
by anonymous

Hello, 

Good day hope your safe and doing well.

I would like you to check this link and read the prerequisites before compiling.
https://wiki.teltonika-networks.com/view/RUT_Software_Development_Kit_instructions
https://wiki.teltonika-networks.com/view/RUTX_Software_Development_Kit_instructions

Hope it helps.

Stay Safe

Regards,
Jerome

by

Hi,

I encounter the same problem as

I tried to build the SDK from within a docker file based on ubuntu:xenial where I installed all the packages from the prerequisites of  both of your provided links. Still I am not able to compile aboot

Maybe some dependencies are only reachable from inside of teltonika network?

I started the actual build with make -j1 V=sc to get a more verbose output:

[...]
make[5]: Entering directory '/opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/aboot-1'
including app/aboot dev/keys dev/pmic/pm8x41 dev/vib lib/debug lib/heap lib/libc lib/libfdt lib/openssl lib/ptable
including lib/openssl/crypto lib/zlib_inflate
generating build-mdm9607/config.h
make[5]: Leaving directory '/opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/aboot-1'
make[5]: *** No rule to make target '/builds/teltonika/rutx_open/staging_dir/toolchain-arm_cortex-a7+neon-vfpv4_gcc-7.3.0_musl_eabi/include/stdc-predef.h', needed by 'build-mdm9607/arch/arm/crt0.o'.  Stop.
make[4]: *** [/opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/aboot-1/.built] Error 2
Makefile:29: recipe for target '/opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/aboot-1/.built' failed
make[4]: Leaving directory '/opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64/package/aboot'
time: package/aboot/compile#0.22#0.60#1.26
package/Makefile:111: recipe for target 'package/aboot/compile' failed
make[3]: *** [package/aboot/compile] Error 2
make[3]: Leaving directory '/opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64'
package/Makefile:107: recipe for target '/opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.package_compile' failed
make[2]: *** [/opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.package_compile] Error 2
make[2]: Leaving directory '/opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64'
make[1]: *** [world] Error 2
Makefile:102: recipe for target 'world' failed
make[1]: Leaving directory '/opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64'
/opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64/include/toplevel.mk:220: recipe for target 'world' failed
make: *** [world] Error 2
The command '/bin/sh -c cd /opt/TRB1XX_SDK/openwrt-gpl-mdm9x07.Linux-x86_64     && make -j1 V=sc' returned a non-zero code: 2
make: *** [Makefile:10: build] Error 2

by anonymous
Hello,

RnD team is already informed about this situation and we are looking for a solution.
by anonymous
Hello,

Fixes for this issue will be released with upcoming 2.4 firmware version.
by
Greetings from Finland!

I ran to this particular issue recently; we just bought a device, and we are planning to replace our existing solution with TRB modem. However, we have a sort of deadline with this, so i'd like to know, whether you have got any schedule for the next FW version?

Regards,
Jouni
by anonymous

Hello,

New RUTOS 2.4.1 version SDK is already available, you can download it from wiki: https://wiki.teltonika-networks.com/view/Software_Development_Kit