4450 questions

5470 answers

8584 comments

5378 members

0 votes
624 views 5 comments
by

Hi guys, after updating the rut950 to RUT9XX_R_00.06.06.1  and manually reconfigured every feature, when I reboot, it doesn't reconnect mobile data automatically, I need to go STATUS-NETWORK-MOBILE and click on "restart connection"

what did I do wrong? I have the troubleashoot file ready to send.

by

Hi !
I have a similar problem for now almost a year. Right now, I have the latest firmware (now 6.06.1). Still it bugs.  
I am convinced it's a RUT950's software problem, because I can fix it manually by doing this:
I switch from Connection type NCM to PPP. Wait 2-3 minutes. Then switch back from PPP to NCM. Wait 2-3 minutes again and then it's Connected & Registered. No reboot.
My carrier is Vodafone 4G GR and I have a static IP.  
I found this solution after a lot of searching in this forum, under various topics (disconnected modem, unregistered issues, fail to obtain static IP, etc). And still, it is not fixed since the firmware v5 !!!
Therefore, I switched RUT950 to be my secondary connection router, using another's manufacturer LTE router as a primary one.

by
thank you Dfousek. I'll try.

update. I tried but I only have PPP and NDIS. find me on fb searching for wer78 please
I also have a secondary issue.

i connected a devolo Powerline wifi AP to a lan port. a W10 laptop and an android 8 phone connect to the internet through that AP. after a while my phone internet stops working while my laptop works. I need to restart the connection on the rut 950 and the phone works normally
Franco
by

this is my configurationscreenshot

by

I have exactly the same problem. We recently upgraded an older RUT950 to RUT9XX_R_00.06.06.1 now mobile does not automatically connect on startup anymore. Our other units in production running older firmware work fine, and this particular test unit worked fine also, until now.

I can confirm that changing the dial profile from NDIS to PPP makes it dial up, then when change back to NDIS is runs fine, it just doesn't start correctly on Boot.

UPDATE: It appears the script that starts an NDIS mobile connection up is either not being called on startup, or is failing (possibly because it's being executed before the device driver is loaded or some other trickery. I haven't ascertained why yet. The workaround is to start it manually after the router has booted using the User Scripts.

In the WEB UI: Navigate to System > User Scripts.

Copy and Paste this text directly above the line exit 0 at the bottom of the script.

/sbin/ndisconn.sh &

Until this bug is fixed by Teltonika this workaround works for me so far.

3 Answers

0 votes
by
Hello,

From the given information it seems that the issue occurs due to the latest firmware version (RUT9XX_R_00.06.06.1) incompatibility with Telit and Huawei mobile modules used in the older RUT devices.

Please write me a personal message with the troubleshoot file attached in order to help me determine what exactly is causing this strange behavior. The troubleshoot file can be downloaded from the System -> Administration -> Troubleshoot WebUI page. It is important to note that the corresponding file needs to be downloaded after an unsuccessful router's attempt to establish a data connection.

Also, it would be great if you could send me two different troubleshoot files - using PPP and NDIS connection protocols.
0 votes
by
Thanks robmcdonald. I implemented your suggestion and it seems to work (first hours of operation). It remains to see if it maintains the connection when it gets connected to another Cell ID. Let's hope that this bug fix will be implemented in the next firmware....
by

Unfortunately, the connection established after reboot due to the /sbin/ndisconn.sh &  is not maintained for long... Is it because, when the router connects to another cell, this line is not executed? Who knows...  

0 votes
by
Hi,

I've just upgraded to RUT9XX_R_00.06.06.1 from the previous version (RUT9XX_R_00.06.06.0 I think) and am now experiencing this same issue. After each reboot, the mobile data is disconnected.

Even sending an SMS to the router with the command "mobileon" doesn't default the router to keeping the mobile state on after reboot.

I've implemented the workaround suggested by RobMcDonald and this seems to have fixed the problem for now. Has anyone else found if this workaround has any problems or limitations I need to be aware of?

Is there anything I can do to help squash this bug going forwards?

Thanks

Adam.